radiotray freezes when site doesn't exist

Issue #272 new
Anonymous created an issue

I have a bunch of radio streams that I adapted from an online list I found. I got them into RT by using regex to make a properly formatted XML file.

I like trying different streams, finding ones I like. All these streams are nicely categorized, but some of them unfortunately no longer exist.

Here is one that's gone: http://80.94.69.106:6104/listen.pls

When I try to connect to that (non-existent) stream, RT just hangs. If I have the Configure Radios dialog open, it too becomes non-responsive.

This is not a complaint, exactly. Just letting you know what's happening.

I frickin' LOVE RadioTray! I love it, it makes my life better, it is tiny and efficient and does it's one thing very, very well.

I'm wondering if there might be a way to avoid the hang, though.

Thanks, and much aloha!

(I'm on Arch, btw.)

Comments (2)

  1. m a r

    That was me above; forgot to sign in.

    Thanks for responding, Ed! I'll give it a try. I got a bit OCD last night and pruned everything, so... Ah! the one I noted above. I'll try that one.

    I also noticed, btw, that if you do several deletions, or use drag and drop to rearrange the menu list in the menu editor, that it doesn't save reliably. One edit seems to work, several edits will work if I wait 10 seconds or so -- but not consistently. Very weird. Should I open another ticket?

    EDIT: tried it, solved the problem. Reduced it to 10 seconds, will probably change it to 6 or 8.

    Mucho aloha!

  2. Log in to comment