Issue #19 resolved

using RAxML_Flags in final genetree pipeline

Vanessa Gonzalez
created an issue

Hi Felipe,

I am trying to run a bootstrap analysis in RAxML. I was trying to give it the RAxML_flags but didn't know how to specify them.

Here is what I tried with my command but it did not work:

$agalma genetree --id 6Taxa_16 --align_id 296 --raxml_flags x_12345 #_100 --model PROTGAMMAWAG --newrun --outdir ../analyses

I want to run 100 rapid bootstraps, which I would normally specify with the RAxML flags: -x 12345 -# 100

I am not sure what is the correct way of specifying them.

Thanks! Vanessa

Comments (4)

  1. Felipe Zapata

    Hi Vanessa,

    Have you tried this?

    $agalma genetree --id 6Taxa_16 --align_id 296 --model PROTGAMMAWAG --newrun --outdir ../analyses --raxml_flags -x 12345 -# 100

    Felipe

  2. Mark Howison

    Yes, this is broken in 0.3.1, but is fixed in our dev branch and slated for 0.3.2.

    The correct usage is:

    --raxml_flags "-x 12345 -# 100"
    

    i.e., the quotes are necessary.

  3. Log in to comment