conda is not installing the latest version

Issue #266 resolved
Cat Munro
created an issue

conda create -c dunnlab -n agalma agalma is installing agalma 1.0.1 not agalma 2.0.0

Comments (4)

  1. Benjamin Evans

    Can you give me some more specifics on your environment(s)? Are you installing into a pre-existing environment? I can't seem to replicate the issue.

    ben@charlie:~$ lsb
    lsblk        lsb_release  
    ben@charlie:~$ lsb_release -a
    LSB Version:    core-9.20170808ubuntu1-noarch:security-9.20170808ubuntu1-noarch
    Distributor ID: Ubuntu
    Description:    Ubuntu 18.04 LTS
    Release:    18.04
    Codename:   bionic
    ben@charlie:~$ conda env list
    # conda environments:
    #
    base                  *  /home/ben/anaconda3
    textblob                 /home/ben/anaconda3/envs/textblob
    
    ben@charlie:~$ conda create -c dunnlab -n agalma agalma
    Solving environment: done
    
    
    ==> WARNING: A newer version of conda exists. <==
      current version: 4.4.10
      latest version: 4.5.4
    
    Please update conda by running
    
        $ conda update -n base conda
    
    
    
    ## Package Plan ##
    
      environment location: /home/ben/anaconda3/envs/agalma
    
      added / updated specs: 
        - agalma
    
    
    The following packages will be downloaded:
    
        package                    |            build
        ---------------------------|-----------------
        python-dateutil-2.7.3      |           py27_0         258 KB
        subprocess32-3.5.0         |   py27h14c3975_0          40 KB
        wheel-0.31.1               |           py27_0          62 KB
        ------------------------------------------------------------
                                               Total:         359 KB
    
    The following NEW packages will be INSTALLED:
    
        agalma:                 2.0.0-py27_0            dunnlab
        biolite:                1.2.0-py27_0            dunnlab
        biolite-tools:          0.4.0-0                 dunnlab
        biopython:              1.68-np111py27_0               
        blast:                  2.5.0-0                 dunnlab
        bowtie:                 1.1.2-py27pl5.22.2.1_0  dunnlab
        bowtie2:                2.3.0-py27pl5.22.2.1_0  dunnlab
        ca-certificates:        2018.03.07-0                   
        cairo:                  1.14.8-0                       
        cd-hit:                 4.6.6-0                 dunnlab
        certifi:                2018.4.16-py27_0               
        curl:                   7.54.1-0                       
        cycler:                 0.10.0-py27hc7354d3_0          
        dbus:                   1.10.20-0                      
        decorator:              4.3.0-py27_0                   
        dendropy:               4.2.0-py27_0            dunnlab
        docutils:               0.13.1-py27_0                  
        ete3:                   3.0.0b35-py27_0         dunnlab
        expat:                  2.2.5-he0dffb1_0               
        fastqc:                 0.11.5-0                dunnlab
        fontconfig:             2.12.1-0                dunnlab
        freetype:               2.5.5-2                        
        functools32:            3.2.3.2-py27h4ead58f_1         
        gblocks:                0.91b-0                 dunnlab
        glib:                   2.50.2-1                       
        gst-plugins-base:       1.8.0-0                        
        gstreamer:              1.8.0-0                        
        icu:                    54.1-0                         
        intel-openmp:           2018.0.0-8                     
        jpeg:                   9b-h024ee3a_2                  
        krb5:                   1.13.2-0                       
        libdb:                  6.1.26-0                dunnlab
        libedit:                3.1.20170329-h6b74fdf_2        
        libffi:                 3.2.1-hd88cf55_4               
        libgcc:                 7.2.0-h69d50b8_2               
        libgcc-ng:              7.2.0-hdf63c60_3               
        libgfortran-ng:         7.2.0-hdf63c60_3               
        libiconv:               1.14-0                         
        libpng:                 1.6.27-0                       
        libssh2:                1.8.0-h9cfc8f7_4               
        libstdcxx-ng:           7.2.0-hdf63c60_3               
        libxcb:                 1.13-h1bed415_1                
        libxml2:                2.9.4-0                        
        libxslt:                1.1.29-0                       
        lxml:                   3.7.2-py27_0                   
        mafft:                  7.305-0                 dunnlab
        matplotlib:             2.0.0-np111py27_0              
        mcl:                    14.137-pl5.22.2.1_0     dunnlab
        mkl:                    2018.0.2-1                     
        ncurses:                6.1-hf484d3e_0                 
        networkx:               1.11-py27h7358325_0            
        numpy:                  1.11.3-py27h3dfced4_4          
        openjdk:                1.8.0.102-13            dunnlab
        openssl:                1.0.2o-h20670df_0              
        pandas:                 0.19.2-np111py27_1             
        parallel:               20160622-pl5.22.2.1_0   dunnlab
        pcre:                   8.39-1                         
        perl:                   5.22.2.1-0              dunnlab
        perl-db-file:           1.835-pl5.22.2.1_0      dunnlab
        perl-scalar-list-utils: 1.45-pl5.22.2.1_0       dunnlab
        perl-uri:               1.69-pl5.22.2.1_0       dunnlab
        pip:                    10.0.1-py27_0                  
        pixman:                 0.34.0-hceecf20_3              
        pycairo:                1.13.3-py27hea6d626_0          
        pyparsing:              2.2.0-py27hf1513f8_1           
        pyqt:                   5.6.0-py27_2                   
        python:                 2.7.11-0                       
        python-dateutil:        2.7.3-py27_0                   
        pytz:                   2018.4-py27_0                  
        qt:                     5.6.2-5                        
        raxml:                  8.2.9-0                 dunnlab
        readline:               6.2-2                          
        rsem:                   1.3.0-pl5.22.2.1_0      dunnlab
        rsem-eval:              1.9-pl5.22.2.1_0        dunnlab
        samtools:               1.2-pl5.22.2.1_0        dunnlab
        setuptools:             39.1.0-py27_0                  
        sip:                    4.19.8-py27hf484d3e_0          
        six:                    1.11.0-py27h5f960f1_1          
        sqlite:                 3.23.1-he433501_0              
        sra-tools:              2.8.0-0                 dunnlab
        subprocess32:           3.5.0-py27h14c3975_0           
        tbb:                    4.4_20150728-0          dunnlab
        tk:                     8.5.18-0                       
        transdecoder:           2.1.0-pl5.22.2.1_0      dunnlab
        trinity:                2.5.1-pl522hf484d3e_0   dunnlab
        unzip:                  6.0-0                   dunnlab
        wget:                   2.2-py27_0              dunnlab
        wheel:                  0.31.1-py27_0                  
        zlib:                   1.2.8-3                        
    
    Proceed ([y]/n)? n
    
  2. Cat Munro reporter

    You're right - must be an issue of a pre-existing environment. I used rm -rf on my local anaconda folder and now I can't replicate that either:

    [cmunro@login002 ~]$ conda env list
    # conda environments:
    #
    base                  *  /users/cmunro/miniconda2
    
    [cmunro@login002 ~]$ conda create -c dunnlab -n agalma agalma
    Solving environment: done
    
    
    ==> WARNING: A newer version of conda exists. <==
      current version: 4.5.1
      latest version: 4.5.4
    
    Please update conda by running
    
        $ conda update -n base conda
    
    
    
    ## Package Plan ##
    
      environment location: /users/cmunro/miniconda2/envs/agalma
    
      added / updated specs: 
        - agalma
    
    
    The following packages will be downloaded:
    
        package                    |            build
        ---------------------------|-----------------
        python-dateutil-2.7.3      |           py27_0         258 KB
        libedit-3.1.20170329       |       h6b74fdf_2         172 KB
        wheel-0.31.1               |           py27_0          62 KB
        biolite-1.2.0              |           py27_0         328 KB  dunnlab
        subprocess32-3.5.0         |   py27h14c3975_0          40 KB
        ncurses-6.1                |       hf484d3e_0         943 KB
        ------------------------------------------------------------
                                               Total:         1.8 MB
    
    The following NEW packages will be INSTALLED:
    
        agalma:                 2.0.0-py27_0            dunnlab
        biolite:                1.2.0-py27_0            dunnlab
        biolite-tools:          0.4.0-0                 dunnlab
        biopython:              1.68-np111py27_0               
        blast:                  2.5.0-0                 dunnlab
        bowtie:                 1.1.2-py27pl5.22.2.1_0  dunnlab
        bowtie2:                2.3.0-py27pl5.22.2.1_0  dunnlab
        ca-certificates:        2018.03.07-0                   
        cairo:                  1.14.8-0                       
        cd-hit:                 4.6.6-0                 dunnlab
        certifi:                2018.4.16-py27_0               
        curl:                   7.54.1-0                       
        cycler:                 0.10.0-py27hc7354d3_0          
        dbus:                   1.10.20-0                      
        decorator:              4.3.0-py27_0                   
        dendropy:               4.2.0-py27_0            dunnlab
        docutils:               0.13.1-py27_0                  
        ete3:                   3.0.0b35-py27_0         dunnlab
        expat:                  2.2.5-he0dffb1_0               
        fastqc:                 0.11.5-0                dunnlab
        fontconfig:             2.12.1-0                dunnlab
        freetype:               2.5.5-2                        
        functools32:            3.2.3.2-py27h4ead58f_1         
        gblocks:                0.91b-0                 dunnlab
        glib:                   2.50.2-1                       
        gst-plugins-base:       1.8.0-0                        
        gstreamer:              1.8.0-0                        
        icu:                    54.1-0                         
        intel-openmp:           2018.0.0-8                     
        jpeg:                   9b-h024ee3a_2                  
        krb5:                   1.13.2-0                       
        libdb:                  6.1.26-0                dunnlab
        libedit:                3.1.20170329-h6b74fdf_2        
        libffi:                 3.2.1-hd88cf55_4               
        libgcc:                 7.2.0-h69d50b8_2               
        libgcc-ng:              7.2.0-hdf63c60_3               
        libgfortran-ng:         7.2.0-hdf63c60_3               
        libiconv:               1.14-0                         
        libpng:                 1.6.27-0                       
        libssh2:                1.8.0-h9cfc8f7_4               
        libstdcxx-ng:           7.2.0-hdf63c60_3               
        libxcb:                 1.13-h1bed415_1                
        libxml2:                2.9.4-0                        
        libxslt:                1.1.29-0                       
        lxml:                   3.7.2-py27_0                   
        mafft:                  7.305-0                 dunnlab
        matplotlib:             2.0.0-np111py27_0              
        mcl:                    14.137-pl5.22.2.1_0     dunnlab
        mkl:                    2018.0.2-1                     
        ncurses:                6.1-hf484d3e_0                 
        networkx:               1.11-py27h7358325_0            
        numpy:                  1.11.3-py27h3dfced4_4          
        openjdk:                1.8.0.102-13            dunnlab
        openssl:                1.0.2o-h20670df_0              
        pandas:                 0.19.2-np111py27_1             
        parallel:               20160622-pl5.22.2.1_0   dunnlab
        pcre:                   8.39-1                         
        perl:                   5.22.2.1-0              dunnlab
        perl-db-file:           1.835-pl5.22.2.1_0      dunnlab
        perl-scalar-list-utils: 1.45-pl5.22.2.1_0       dunnlab
        perl-uri:               1.69-pl5.22.2.1_0       dunnlab
        pip:                    10.0.1-py27_0                  
        pixman:                 0.34.0-hceecf20_3              
        pycairo:                1.13.3-py27hea6d626_0          
        pyparsing:              2.2.0-py27hf1513f8_1           
        pyqt:                   5.6.0-py27_2                   
        python:                 2.7.11-0                       
        python-dateutil:        2.7.3-py27_0                   
        pytz:                   2018.4-py27_0                  
        qt:                     5.6.2-5                        
        raxml:                  8.2.9-0                 dunnlab
        readline:               6.2-2                          
        rsem:                   1.3.0-pl5.22.2.1_0      dunnlab
        rsem-eval:              1.9-pl5.22.2.1_0        dunnlab
        samtools:               1.2-pl5.22.2.1_0        dunnlab
        setuptools:             39.1.0-py27_0                  
        sip:                    4.19.8-py27hf484d3e_0          
        six:                    1.11.0-py27h5f960f1_1          
        sqlite:                 3.23.1-he433501_0              
        sra-tools:              2.8.0-0                 dunnlab
        subprocess32:           3.5.0-py27h14c3975_0           
        tbb:                    4.4_20150728-0          dunnlab
        tk:                     8.5.18-0                       
        transdecoder:           2.1.0-pl5.22.2.1_0      dunnlab
        trinity:                2.5.1-pl522hf484d3e_0   dunnlab
        unzip:                  6.0-0                   dunnlab
        wget:                   2.2-py27_0              dunnlab
        wheel:                  0.31.1-py27_0                  
        zlib:                   1.2.8-3          
    
  3. Log in to comment