Commits

catapela committed d3173b4

some small error message changes

  • Participants
  • Parent commits 3c8a60e

Comments (0)

Files changed (1)

File dynamicLink/__init__.py

 
     # check dynaic link dependences
     if djv < smalest_dlv:
-        print('Django %s is not supported. Please install a more recent django version.' % str(djv))
+        print('Django %s is not supported. With this version of dynamicLink, Django %s is recommended. Use "pip install django==%s.X"'\
+        % (str(djv), str(greatest_dlv).strip('()').replace(' ', ''), str(greatest_dlv).strip('()').replace(' ', '') ))
     elif djv > greatest_dlv:
-        print('This Version on dynamicLink (try: dynamicLink.VERSION) needs an older Django release (try: dynamicLink.RELEASE_DJANGO). Use "pip install django==%s.X"' % str(greatest_dlv))
+        print('This Version of dynamicLink (try: dynamicLink.VERSION) needs an older Django release (try: dynamicLink.RELEASE_DJANGO). \
+        Try "pip install --upgrade django-dynamic-link" or use "pip install django==%s.X". '\
+        % str(greatest_dlv).strip('()').replace(' ', ''))
     elif sys.version_info < version.PYTHON:
         print('dynamicLink depends on python %s or higher.' % str(version.PYTHON))
     else: