Commits

catapela committed e4b557b

some changes

Comments (0)

Files changed (1)

dynamicLink/__init__.py

     """function to find problems of the installation."""
 
     print('I try to find errors for you!')
-    djv = django.VERSION
+    djv = django.VERSION[:2]
     greatest_dlv = version.RELEASE_DJANGO[0]
     smalest_dlv = version.RELEASE_DJANGO[0]
 
 
     # check dynaic link dependences
     if djv < smalest_dlv:
-        print('Django %s is not supported. With this version of dynamicLink, Django %s is recommended.' \
-        'Use "pip install django==%s.X"' \
+        print('Django %s is not supported. With the installed version of dynamicLink is Django %s recommended. ' \
+        'Use "pip install django==%s.X". ' \
         'To display all supported django versions use "dynamicLink.RELEASE_DJANGO".' \
-        % (str(djv), strform(greatest_dlv), strform(greatest_dlv) ))
+        % (str(django.VERSION), strform(greatest_dlv), strform(greatest_dlv) ))
     elif djv > greatest_dlv:
-        print('This Version of dynamicLink (try: "dynamicLink.VERSION") needs an' \
-        'older Django release (try: "dynamicLink.RELEASE_DJANGO").' \
+        print('This Version of dynamicLink (try: "dynamicLink.VERSION") needs an ' \
+        'older Django release (try: "dynamicLink.RELEASE_DJANGO"). ' \
         'Use "pip install --upgrade django-dynamic-link" or use "pip install django==%s.X". '\
         % strform(greatest_dlv))
     elif sys.version_info < version.PYTHON:
-        print('Error! Wrong python version. dynamicLink depends on python %s or higher.' \
+        print('Error! Wrong python version. dynamicLink depends on python %s or higher. ' \
         'With this python installation dynamicLink will not work properly!' \
         % strform(version.PYTHON))
     else: