Add an option to disable the use of the PCRE library

Create issue
Issue #241 resolved
Paul Turner created an issue

Add a compile time / configure option to disable use of the (currently mandatory) PCRE library.

Reproducibility: N/A

Additional information: Without PCRE things such as input restriction / validation on editbox based widgets (including the entire spinner widget) would need to be excluded from the build.

Originated here: http://www.cegui.org.uk/phpBB2/viewtopic.php?t=3600

Comments (1)

  1. Paul Turner reporter

    added new option in trunk @ rev. 2120.

    NB: The affected areas are not removed from the code - thus keeping the API in tact whatever the config, however, attempts to set the validation string without any regex support available will throw InvalidRequestException.

  2. Log in to comment