1.13.1 breaks pymunk on linux in a subtle way

Create issue
Issue #432 resolved
Victor Blomqvist created an issue

It seems like something in the latest release (1.13.1) breaks some things in the python library pymunk as described in this github issue: https://github.com/viblo/pymunk/issues/171

I have tried to debug, and it seems to be something that happens on Linux (tested on ubuntu) on CPython. On Windows it works as expected. I tried readin the changelog for 1.13.1 but could not see any obvious reasons why it would stop working or break in the way it does.

Comments (6)

  1. Armin Rigo

    It works fine with cffi 1.13.1 built locally, but it fails with the cffi 1.13.1 installed from pip. Still investigating.

  2. Armin Rigo

    I think that the problem is site-packages/.libs_cffi_backend/libffi-10449faf.so.5.0.6, which is buggy. I think this version of libffi was put there by the manylinux build of 1.13.1, which was done on Azure Pipelines. I have no idea how to work around this issue so far.

  3. Armin Rigo

    OK, fixed in new version. Now I only need to bump the version number, rebuild all the wheels, upload them as atomically as possible to avoid the previous mess where only the source wheel was available for three hours and many people complained; then ask Alex to rebuild additional wheels and upload them too. That looks like it'll have to wait until I have a few hours ahead of me.

  4. Armin Rigo

    Released 1.13.2! If you can try it with pymunk it would be great. It seems that the tests are passing again on Linux on CPython 2.7.

  5. Log in to comment