Acro package provides “! Missing number, treated as zero.” after update

Issue #96 resolved
Anonymous created an issue

Copy from https://tex.stackexchange.com/questions/383018/acro-package-provides-missing-number-treated-as-zero-after-update

I ran an update on texlive 2017 (via tlmgr) and I got an error for the acro package that I have not experienced before.

I have provided a MWE:

\documentclass{article}

\usepackage{acro}
\DeclareAcronym{RES}{
    short = RES ,
    long = Renewable Energy Sources ,
}
\listfiles
\begin{document}
    \ac{RES}
\end{document}

This is my output for \listfiles

*File List*
 article.cls    2014/09/29 v1.4h Standard LaTeX document class
  size10.clo    2014/09/29 v1.4h Standard LaTeX file (size option)
    acro.sty    2017/06/21 v2.7b Typeset Acronyms
   expl3.sty    2017/07/19 L3 programming layer (loader) 
expl3-code.tex    2017/07/19 L3 programming layer 
l3pdfmode.def    2017/03/18 v L3 Experimental driver: PDF mode
  xparse.sty    2017/07/19 L3 Experimental document command parser
l3keys2e.sty    2017/07/19 LaTeX2e option processing using LaTeX3 keys
xtemplate.sty    2017/07/19 L3 Experimental prototype document functions
etoolbox.sty    2017/01/02 v2.4 e-TeX tools for LaTeX (JAW)
zref-abspage.sty    2016/05/21 v2.26 Module abspage for zref (HO)
zref-base.sty    2016/05/21 v2.26 Module base for zref (HO)
 ltxcmds.sty    2016/05/16 v1.23 LaTeX kernel commands for general use (HO)
infwarerr.sty    2016/05/16 v1.4 Providing info/warning/error messages (HO)
kvsetkeys.sty    2016/05/16 v1.17 Key value parser (HO)
etexcmds.sty    2016/05/16 v1.6 Avoid name clashes with e-TeX commands (HO)
ifluatex.sty    2016/05/16 v1.4 Provides the ifluatex switch (HO)
kvdefinekeys.sty    2016/05/16 v1.4 Define keys (HO)
pdftexcmds.sty    2017/03/19 v0.25 Utility functions of pdfTeX for LuaTeX (HO)
   ifpdf.sty    2017/03/15 v3.2 Provides the ifpdf switch
 auxhook.sty    2016/05/16 v1.4 Hooks for auxiliary files (HO)
atbegshi.sty    2016/06/09 v1.18 At begin shipout hook (HO)
translations.sty    2017/05/16 v1.6 internationalization of LaTeX2e packages (C
N)
scrlfile.sty    2017/04/13 v3.23 KOMA-Script package (loading files)
translations-basic-dictionary-english.trsl    (english translation file `transl
ations-basic-dictionary')
 ***********

and this is the error in the log-file:

! Missing number, treated as zero.
<to be read again> 
                   \l__acro_RES_long-plural_set_bool 
l.7 }

A number should have been here; I inserted `0'.
(If you can't figure out why I needed to see a number,
look up `weird error' in the index to The TeXbook.)

Could it be linked to the packages acro requires? They seem to be updated.

Comments (8)

  1. u_fischer

    As a work-around one can try to add a test for the boolean(s). I have no idea if it disables some functionality.

    Edit 31.7.: I changed the inner code of the new boolean test, as I think that this reinstates the old behaviour.

    \documentclass[paper=a4,fontsize=12pt, twoside, BCOR=8mm]{scrbook}
    \usepackage{acro}
    \ExplSyntaxOn
    
     \cs_undefine:N\__acro_declare_long:nn
     \acro_declare_property:nnn {long} {long}
      {
        \acro_for_endings_do:n
          { \prop_put:cnn {l__acro_long_##1_form_prop} {#1} { \c_false_bool } }
        \prop_put:NnV \l__acro_long_indefinite_prop
          {#1}
          \l__acro_default_indefinite_tl
        \acro_for_endings_do:n
          {
           \bool_if_exist:cTF {l__acro_#1_long-##1_set_bool}
            {
              \bool_if:cF {l__acro_#1_long-##1_set_bool}
              {
               \prop_put:cnv {l__acro_long_##1_prop} {#1} {l__acro_default_long_##1_tl}
              }
            }
            {
             \prop_put:cnv {l__acro_long_##1_prop} {#1} {l__acro_default_long_##1_tl}
            }
          }
      }
    
    \ExplSyntaxOff
    \DeclareAcronym{RES}{short = RES, long = Renewable Energy Sources}
    \DeclareAcronym{PRES}{short = RES, long = Renewable Energy Sources}
    \DeclareAcronym{TRES}{short = RES, long = Renewable Energy Sources}
    
    \begin{document}
        \ac{RES}
    \end{document}
    
  2. Mike

    I can experience the same with pdflatex. Unbelievable. 2 weeks ago all worked fine. Hope, Clemens will solve it fast. This work around will be tested tomorrow. Thanks.

  3. Mike

    I thought that I download an old version, put in the document's directory and it will work. It isn't working. My solution was to delete MacTex completely and reinstall it. Now, it's working. Hope, you will provide pieces of information asap when the issue is solved.

  4. Log in to comment