Issue #315 resolved

Install fails with Python 2.3

Anonymous created an issue

CherryPy 2.1 is supposed to be compatible with Python 2.3 as per http://www.cherrypy.org/file/tags/cherrypy-2.1.0-rc1/README.txt .

Install on a box with Python 2.3 fails with following error {{{ byte-compiling /usr/lib/python2.3/site-packages/cherrypy/test/cp_decorator_tests.py to cp_decorator_tests.pyc File "/usr/lib/python2.3/site-packages/cherrypy/test/cp_decorator_tests.py", line 4 @cherrypy.expose("1") ^ SyntaxError: invalid syntax

}}}

Work-around: Delete file cherrypy/test/cp_decorator_tests.py before beginning install.

I hope cherrypy will continue supporting Python2.3. We have taken serious business decision to use CherryPy in our product and 2.3 compatibility was one of the assumptions based on Prerequisites mentioned at http://www.cherrypy.org/wiki/CherryPyInstall .

Reported by pythonic@gmail.com

Comments (3)

  1. Anonymous

    I'll look into this issue later but I can already assure you that CP will definitely support Python-2.3

  2. Log in to comment