Issue #484 resolved

CherryPy on svn trunk since [1006] is no longer compatible with Python 2.3

Anonymous created an issue

A "python setup.py install" with my Python (2.3.5, generic x86 Gentoo Linux) on a current working copy of the CherryPy trunk chokes during the byte-compile phase, 'cos Python 2.3.5 apparently doesn't have decorators, and wsgiappfilter.py uses @cherrypy.exposed in its example.

Fix is trivial. Patch attached soon.

Reported by horatio@computer.org

Comments (2)

  1. Log in to comment