Issue #440 resolved

deprecationwarning in cherrypy.lib.filter should properly tell you where the problem is

anonymous
created an issue

It's a trivial change:

{{{ Index: cherrypy/lib/filter/init.py =================================================================== --- cherrypy/lib/filter/init.py (revision 926) +++ cherrypy/lib/filter/init.py (working copy) @@ -1,5 +1,5 @@ import warnings -warnings.warn("cherrypy.lib.filter has been superseded by cherrypy.filters and will be removed in CP 2.3") +warnings.warn("cherrypy.lib.filter has been superseded by cherrypy.filters and will be removed in CP 2.3", DeprecationWarning, stacklevel=2)

from cherrypy.filters import * }}}

Comments (4)

  1. Log in to comment