BAM2chicago awk error

Create issue
Issue #28 resolved
Pablo Acera created an issue

Hi! thanks in advance.

I am trying to generate .chinput files using script. I am using the .rmap and .baitmap files from PCHiCdata. Then, I am downloading the first 10M read from the SRA SRR3535023, the experiment from the CHiCAGO paper. I used HiCUP to generate the bam file. I have tried to use the whole hg19 ref. genome, and also with just chromosome 20 and 21 as the .rmap and .baitmap files contain just these chromosomes. I have the same error.

C02SG006FVH6:out_bam2chicago pacera$ ../out_hicup/SRR3535023_1_2.hicup.bam /Users/pacera/developing/C-HiC/tests/data/hg19TestDesign/h19_chr20and21.baitmap /Users/pacera/developing/C-HiC/tests/data/hg19TestDesign/h19_chr20and21.rmap output Checking rmap and baitmap files... Rmap and baitmap files checked successfully Processing sample output... Using bam file ../out_hicup/SRR3535023_1_2.hicup.bam Using baitmap file /Users/pacera/developing/C-HiC/tests/data/hg19TestDesign/h19_chr20and21.baitmap Using digest map (rmap) file /Users/pacera/developing/C-HiC/tests/data/hg19TestDesign/h19_chr20and21.rmap Baitmap file contains >4 columns. Checking if /Users/pacera/developing/C-HiC/tests/data/hg19TestDesign/h19_chr20and21.baitmap_4col.txt exists... Found /Users/pacera/developing/C-HiC/tests/data/hg19TestDesign/h19_chr20and21.baitmap_4col.txt Intersecting with bait fragments (using min overhang of 0.6)... Flipping all reads that overlap with the bait on to the right-hand side... Intersecting with bait fragments again to produce a list of bait-to-bait interactions that can be used separately; note they will also be retained in the main output... Intersecting with restriction fragments (using min overhang of 0.6)... Removing reads that failed the min overhang filter... awk: division by zero source line number 12

I do not know how to proceed, please could you give my a hint here? thank you very much for your time.

Comments (2)

  1. Mikhail Spivakov

    Hi Pablo, I've just updated the repo with a patch that should fix this error for you. Hope this helps!

  2. Log in to comment