What does the following messenge mean after I ran runChicago.R

Create issue
Issue #54 new
Mai Xu created an issue

I got the following error messenger after running runChicago.R-could anyone please let me know what it means? It was killed right after starting and looks like one file may have a bad format, but which one? All the design files and input file were genegrated by Chicago pipeline. Thank you!

[+] Loading bedtools 2.22.0
[+] Loading perl 5.18.2 on cn3247
[+] Loading gcc 9.2.0 ...
[+] Loading GSL 2.6 for GCC 9.2.0 ...
[-] Unloading gcc 9.2.0 ...
[+] Loading gcc 9.2.0 ...
[+] Loading openmpi 3.1.4 for GCC 9.2.0
[+] Loading ImageMagick 7.0.8 on cn3247
[+] Loading HDF5 1.10.4
[+] Loading pandoc 2.9.1 on cn3247
[+] Loading R 3.6.1


Error in (function (object, class, nargs) :
Invalid argument value: expecting numeric but got: (1e+06).
Calls: parse_args -> mapply -> <Anonymous>
Execution halted

Comments (4)

  1. Adrija Kalvisa

    It is likely that one of your bed-like files contains integers that have been automatically converted to a scientific number. Try running grep "1e+06" <filename> on files that you use as an input for runChicago.R to find which file has the fault.

    I hope this will help you 🙂

  2. Mai Xu reporter

    Thanks, Adrija! We realized this problem and changed the R profile setting to accommodate this problem.


  3. Arpit Suresh Mishra

    Hi Mai what solution did you use, I tried playing with (scipen = 999) but it didn't help.

    Hi Adrija, In my bed like files I didn't see any “1e+06”

  4. Mai Xu reporter

    Here is the command line I used to solve the problem:

    echo "options(scipen=999)" >>~/.Rprofile

    Hope that helps!


  5. Log in to comment