clonesatchmo.py failure

Issue #1070 resolved
Jonathan Hayward
created an issue

I have so far not succeeded at getting anywhere near passing a smoke test in creating a Satchmo clone to work on a project.

I am trying to install Satchmo 0.9 on an Ubuntu 9.10 32-bit guest off of the instructions at http://bitbucket.org/chris1610/satchmo/downloads/Satchmo.pdf. I run into difficulties at 2.1.2:

{{{ pip install -r http://bitbucket.org/chris1610/satchmo/raw/tip/scripts/requirements.txt pip install -e hg+http://bitbucket.org/chris1610/satchmo/@v0.9#egg=satchmo }}} The first command fails because a compile error for how it's trying to build PIL. So I ran an "aptitude install python-imaging", locally copy the first line's requirements.text, and remove the line that's unsuccessfully trying to build PIL. The first line completes without reported error, as does the second.

The next step tells me to change directory to the /path/to/new/store, and run: {{{ python clonesatchmo.py }}} A little bit of trouble here; I am told that clonesatchmo.py will be in /bin by now, and it isn't there, but I put some Satchmo stuff under /usr/local, create a symlink in /bin, and run: {{{ python /bin/clonesatchmo.py }}} This gives: {{{ jonathan@ubuntu:~/store$ python /bin/clonesatchmo.py Creating the Satchmo Application Traceback (most recent call last): File "/bin/clonesatchmo.py", line 108, in <module> create_satchmo_site(opts.site_name) File "/bin/clonesatchmo.py", line 47, in create_satchmo_site import satchmo_skeleton ImportError: No module named satchmo_skeleton }}} A find after apparently checking out the repository reveals that there is no file with a name like satchmoskeleton on my system. I thought that bash might be prone to take part of the second pip invocation's URL as the beginning of a comment; I tried both: {{{ pip install -e hg+http://bitbucket.org/chris1610/satchmo/@v0.9#egg=satchmo pip install -e hg+http://bitbucket.org/chris1610/satchmo/@v0.9#egg=satchmo }}} Neither way of doing it seems to take care of the import error mentioned above. So far I have completely failed to achieve "Hello, world!"/smoke test functionality.

Comments (1)

  1. Log in to comment