newsletter/mailman.py is not python 2.4 compatible

Issue #112 resolved
Anonymous created an issue

I noticed that satchmo/newsletter/mailman.py was not working with python2.4. It requires python2.5 due to the use of try: except: finally:

To make it work with python2.4, one has to nest the "try: except:" part. {{{ try: try: do except: fail finally: clean }}} So, if you care about python2.4 compatibility (I do, python2.4 is still the default on Debian stable), please apply the attached patch (not tested, but so trivial that I hope to get it right).

Reported by rhertzog

Comments (1)

  1. Log in to comment