1. Chris Moffitt
  2. satchmo
Issue #1333 resolved

clonesatchmo.py says Invalid skeleton directory

lucy_brennan
created an issue

I installed Satchmo from scratch, with: pip install satchmo

Tried: {{{ $ clonesatchmo.py Creating the Satchmo Application Invalid skeleton directory. Path should be /path/to/satchmo/projects/skeleton }}}

I understand what it is looking for. And I might be able to find out where that is. But then, what variable should I set? Or should I set an environment variable? Or smth else?

So the problem is both that it does not work from scratch and that the error message does not tell me what to do about it. It could help too, if it told me where it is currently looking, i.e. where it is expecting them to be

Comments (7)

  1. scrapper

    i just say hello, i have already answered your previous topics. and i don't know what to say right now. its really too late, and i am still at beginning with little beer number 3. :-)

    I guess you have messed up with your folder structure.

    Stay tuned with Satchmo and you will be able to answer your questions soon. Just follow the Tutorial and Install Instructions. They worked for me, I am sure they will help you more on that big project than I could within days.

    Good night Lucy

    sc

    ps.: don't ask for master plan, be smart and ask specific questions.

  2. lucy_brennan reporter

    It might not be Satcho's fault. It seems to only happen when I make the project in a virtualenv, using http://pypi.python.org/pypi/virtualenv.

    So I set up a virtual environment virtualenv. And I activated it.

    The command 'which' tells me what I expect: $ which clonesatchmo.py /home/lucy/Desktop/satchmo_virtual_env/bin/clonesatchmo.py

    But when calling it, it tries to call the 'global' version (which is now uninstalled): $ clonesatchmo.py bash: /usr/local/bin/clonesatchmo.py: No such file or directory

    So, before uninstalling the 'global' installation of satchmo, it was being called, when the pythonpath was pointing to a different installation. I believe that is how the problem was arose.

  3. scrapper

    Chris was asking this question, when someone a while ago asked for help on similar issue: How did you download the source code? Does it include the skeleton directory at the pat you point it to?

    -Chris from: <<issue http://www.mail-archive.com/satchmo-users@googlegroups.com/msg04570.html>>

    I think you have to redo your installation tutorial, and look for the right way. So it seems your paths are wrong. I am not running virtualenvs.. can't help you on that.

    good luck

    sc

  4. Stephen Mitchell

    This error will appear if you use

    pip install satchmo
    

    Using the command in the quickstart guide:

    pip install -e hg+http://bitbucket.org/chris1610/satchmo/#egg=satchmo
    

    will fix the issue.

  5. guitarmanvt

    This isn't really an "invalid" question. I had the exact same issue. I did pip install from the Bitbucket egg, inside my brand new virtualenv. I had the same error. After reading the clonesatchmo.py script, here's the solution that worked for me:

    clonesatchmo.py --skel $VIRTUAL_ENV/lib/python2.7/site-packages/satchmo_skeleton
    

    I'm using virtualenvwrapper, virtualenv 1.7.1.2, satchmo 0.9.2, and pip 1.1, on Linux Mint 13.

  6. Log in to comment