Admin static files with wrong urls in clonesatchmo

Issue #1419 resolved
Anonymous created an issue

I followed the instructions at to install satchmo and I was able to install everything correctly (I think) on an ubuntu 11.04 machine.

The pip commands installed django 1.3.1 and satchmo 0.9.3

Then I ran "python" command successfully and then ./ runserver. The server started with no errors, but when I tried to access , all the static files were not loaded. Looking at the html source code of the page, all of them were at /media/css/

Something may be broken.

Comments (3)

  1. Anonymous


    Since no one has answered you.

    I have the same problem with a fresh install of Satchmo. Just to make sure I installed satchmo0.9.2 which does not have this issue.

    I am a new user, and I am presently learning how to use Satchmo/Django so I am unable to offer any assistance at this time.


    John Boyd

  2. Anonymous


    It seems that the requirements.txt file as used in the quickstart needs some updating.

    I made up my own requirements.tx file that uses "django" instead of "django>=1.2.3,<=1.3.9". pip now installs Django-1.4.

    Second, I got the error "Invalid block tag: 'thumbnail', expected 'else' or 'endif'" . I reinstalled sorl-thumbnail using "pip install --upgrade sorl-thumbnail."

    Therefore I think the offending line in the requirements.txt file is "-e hg+" change this to just "sorl-thumbnail"

    Note: I am using a virtualenv on Ubuntu 10.04. I don't know what os you are using. If you are interested in my requirements.txt file and instructions on how I did my install, just say and I will post it here.



  3. Log in to comment