PRODUCT:CATEGORY slug keeps disappearing from live settings

Issue #946 resolved
Jason Christa
created an issue

I have set the value several times now and couple times directly in the database. Somehow without touching the admin section at all after a while the setting is removed from the database all other settings appear to be in tact.

Comments (5)

  1. Jason Christa reporter

    Even adding :

    LIVESETTINGS_OPTIONS = {
        1 : {
            'DB' : False,
            'SETTINGS' : {
                    'PRODUCT' : {
                        'CATEGORY_SLUG' : 'category',
                    }
                }
            }
        }
    

    did not solve the problem. I was still getting errors saying that setting could not be read.

    The problem appears to be fixed by rolling all the way back the .9 rc1 branch.

  2. Jason Christa reporter

    Are you referring to adding the default values to the config_value calls?

    If that does work, it would only be masking whatever the problem is.

    In trying to solve the problem, I use the file cache so I deleted the files manually and reset the server for good measure, which didn't solve the problem. The real oddity is even with LIVESETTINGS_OPTIONS set I could trigger the error, periodically. The error triggers disproportionately in the private browsing modes of both Chrome and IE, though I am not sure what that has to do with anything.

    None the less having default parameters couldn't hurt and generating a possibly incorrect link is much friendlier than displaying a server error page.

  3. Chris Moffitt repo owner

    Try this other fix from a related thread:

    On line 47 in satchmo.apps.livesettings.models the cache-miss logic is calling 'loading.app_cache_ready()' In our case that method is always returning false. Thus, the database-value is never loaded, and Satchmo creates a new Setting object in it's place. When this new setting is saved to the db, it's triggering the IntegrityError.

    I ran into a similar problem once and implemented this change and it worked. I'd be curious to see if it works for you.

  4. Log in to comment