Commits

Robert Brewer committed af596d2

Fixed #1093 (setup.py doesn't work for python < 2.5)

Comments (0)

Files changed (1)

     "Custom version of build_py that selects Python-specific wsgiserver"
     def build_module(self, module, module_file, package):
         python3 = sys.version_info >= (3,)
-        exclude_pattern = re.compile(
-            'wsgiserver2|ssl_pyopenssl' if python3 else 'wsgiserver3'
-        )
+        if python3:
+            exclude_pattern = re.compile('wsgiserver2|ssl_pyopenssl')
+        else:
+            exclude_pattern = re.compile('wsgiserver3')
         if exclude_pattern.match(module):
             return # skip it
         return build_py.build_module(self, module, module_file, package)