1. Christian Specht
  2. RoboShell Backup
Issue #6 resolved

Robocopy Issue?

Gilbert Delagarza
created an issue

Ran first job that copied Music, Photos and Videos to a Lacie Cloudbox NAS device. After finished reran again so it would pick up differences on source drive and getting these messages over and over.

0 C:\Users\PC\Pictures\05192012\$Application Data\2013/01/13 17:31:16 ERROR 2 (0x00000002) Changing File Attributes C:\Users\PC\Pictures\05192012\$Application Data\ The system cannot find the file specified.

It also gets this same message when trying to set attributes on the remote NAS drive (S:)

Comments (4)

  1. Christian Specht repo owner

    Is the date and time ($Application Data\2013/01/13 17:31:16) really part of the path or is there just a line break missing because of copy & paste?

    What happens when you use Robocopy alone (without RoboShell Backup)?
    Try this:

    robocopy "c:\sourcepath" "s:\destinationpath" *.* /mir
    

    Do you get the same error message?

    Are you sure that everything is alright with your NAS drive? The fact that trying to set attributes produces the same message makes me suspect that something may be wrong with the NAS.

  2. Gilbert Delagarza reporter

    I figured it out earlier. Because I am using Windows 7 SP1 the permissions were prohibiting from changing the attributes on the source files and then write permissions to the target drive. So I took ownership of the folders I wanted to copy and copied them again and then when I ran the job again it worked pefectly! I tweaked the robocopy settings to this: robocopy.exe "$from" "$to" . /MIR /E /R:2 /W:5 /xj /fft Because of the EXT4 file system the "/fft" switch seems to work better. But I am impressed with this script! Lots of different ways I can make different instances of this script. Already have this running as a schedule task now. Thanks!

  3. Christian Specht repo owner

    Glad to hear that it worked for you!

    But I'm a bit puzzled that you made it work by reducing the number of retries and the wait time between retries.
    Then again, I know nothing about EXT4/Linux. My own NAS runs on Linux as well, but that's all I know. I had to do nothing special to make RoboShell Backup (and RoboCopy in general) work with it.

  4. Log in to comment