Branch 2883 pac proxy not work

Issue #2066 resolved
Peiyuan Song created an issue

My self build and build download from http://opensource.spotify.com/cefbuilds/index.html#windows64_builds the PAC proxy can not take effect. I tried bouth CEF 3.2883.1536.ga8ecb19 / Chromium 55.0.2883.44 x64 and CEF 3.2883.1539.gd7f087e / Chromium 55.0.2883.59 x64 build on windows 10. the cefclient screenshots version 3.2883.1539.gd7f087e / 55.0.2883.59 cef.png

here is a work pac proxy screenshots from Chrom 55.0.2883.59 (64-bit) chrome55.png old version cef pac proxy work will.

Comments (18)

  1. Peiyuan Song reporter

    This is system pac proxy config, I am running the cefclient directly, and the old version of the cefclient is no problem. And only pac proxy can not be effective, there is no problem with the system http proxy.

  2. Peiyuan Song reporter

    Test with --proxy-pac-url=http://192.168.1.156/dmm.pac option, the pac proxy still not take effect. cefproxy.png

  3. Victor Tran

    I'm having the same issue here, only I'm not using a manually entered PAC autoconfig file. I noticed that in the console output, CEF continually prints

    [1207/075437:ERROR:interface_registry.cc(99)] Capability spec prevented service service:content_browser from binding interface: net::interfaces::ProxyResolverFactory
    

    Would that have anything to do with it? :)

  4. Peiyuan Song reporter

    [0125/153135:VERBOSE1:utility_process_mojo_proxy_resolver_factory.cc(48)] Attempting to create utility process for proxy resolver
    [0125/153137:VERBOSE1:node.cc(392)] Merging local ports 20EE05E2E94FEE7B.23BDF387D40B51B2@DC57FFE614B0E5BE.6C2AE22243357D43 and 835D0FF5CE4A567D.BF245E1DC2ACE4B7@DC57FFE614B0E5BE.6C2AE22243357D43
    [0125/153137:VERBOSE1:node_controller.cc(894)] Parent DC57FFE614B0E5BE.6C2AE22243357D43 accepted child 6015C6922732ED35.6509F9EA093E70E4
    [0125/153137:VERBOSE1:node.cc(366)] Sending MergePort from 10AE0790449DF37B.C33AC85B8786ADC6@DC57FFE614B0E5BE.6C2AE22243357D43 to 8D81CC6212966B9D.57381AEB28803137@6015C6922732ED35.6509F9EA093E70E4
    [0125/153138:VERBOSE1:utility_process_mojo_proxy_resolver_factory.cc(93)] Disconnection from utility process detected
    [0125/153138:VERBOSE1:node.cc(536)] ObserveProxy: 8244A70A62B9E24B.1FFCE830804C8961@DC57FFE614B0E5BE.6C2AE22243357D43 not found
    [0125/153138:VERBOSE1:node_controller.cc(562)] Dropped peer 6015C6922732ED35.6509F9EA093E70E4
    [0125/153138:VERBOSE1:node.cc(413)] Observing lost connection from node DC57FFE614B0E5BE.6C2AE22243357D43 to node 6015C6922732ED35.6509F9EA093E70E4
    [0125/153138:VERBOSE1:node_controller.cc(684)] Dropping message for unknown peer: 6015C6922732ED35.6509F9EA093E70E4
    [0125/153146:VERBOSE1:proxy_service.cc(1259)] Failed configuring with PAC script, falling-back to manual proxy servers.
    [0125/153146:VERBOSE1:histogram.cc(377)] Histogram: Net.ProxyService.ResolveProxyTime has bad minimum: 0
    [0125/153146:VERBOSE1:spdy_session_key.cc(21)] SpdySessionKey(host=www.google.com:80, proxy=direct://, privacy=0
    
    new debug log, I found the V8 Proxy Resolver utility process exit immediately after it created.

  5. Akintoye Olorode

    Debugging shows that utility process launch advances up to point where CreateProcessAsUserW is called. However, the main function is not ever executed. Setting command line switch "--no-sandbox" did not change behavior. Any ideas to guide further investigation ?

  6. Akintoye Olorode

    Adding command line switch "--winhttp-proxy-resolver" solved problem for my use case viz : Accessing internet behind corp proxy (each desktop is configured to download .pac from internal address).

  7. Akintoye Olorode

    I should add we are only concerned with Windows OS. I cannot say how this switch affects behavior on other OSes.

  8. Marshall Greenblatt

    Pac configuration appears to be working in 2924 branch and newer for me. Tested on Windows 10 using cefclient with --proxy-pac-url=http://pac.webdefence.global.blackspider.com:8082/proxy.pac (randomly selected public pac file).

  9. Marshall Greenblatt

    Marking this issue as WontFix since the problem does not reproduce for me with currently supported branches (2924 and newer). If you experience this issue with supported branches then we can re-open.

  10. zhagan

    PAC proxy can not take effect

    I am testing cefsharp(53.0.1.0) winfom, and try to enable the pac proxy which had been set by "shadowsocks", the pac proxy works fine in IE and Chrome browser.

    I got Command Line args "--proxy-pac-url" from : http://peter.sh/experiments/chromium-command-line-switches/ and added it to the CefExample Init method as following:

    settings.CefCommandLineArgs.Add("--proxy-pac-url", "http://127.0.0.1:1080/pac?t=20170209085145204&secret=GL8ufyUpE98QSjWLnzJe9GF/suuzNfmwhpGEMWcsirM=");

    However ,it doesn't work, I can't visit google.com with the pac proxy (I am from china and google.com is banned.)

    So anybody can tell me how to deal with pac proxy in cefsharp winform?

  11. Marshall Greenblatt

    @zhagan : As stated above the issue is resolved in branch 2924 and newer. You should update to a CefSharp version using that branch. If you need assistance doing that please ask in the appropriate CefSharp support forum.

  12. Marshall Greenblatt

    Confirmed working in 3.3202.1692.g18a939d_windows32 and broken in 3.3239.1710.g85f637a_windows32 on Windows 10 with cefclient.exe --proxy-pac-url=http://pac.webdefence.global.blackspider.com:8082/proxy.pac.

    In current master it's failing with:

    [1227/161630.078:ERROR:instance.cc(49)] Unable to locate service manifest for proxy_resolver
    [1227/161630.079:ERROR:service_manager.cc(890)] Failed to resolve service name: proxy_resolver
    
  13. Log in to comment