Missing polish diacritics

Issue #3120 duplicate
Jakub created an issue

Hello,

I have an issue with the chromium as it does not handle upper cased polish diacritics. It is reproducible 100%

  1. holding LeftShift + RightAlt + PressKey (A, E, O, N, C, S, L, Z, X)
  2. The expected output is Ą, Ę, Ó, Ń, Ć, Ś, Ł, Ż, Ź, but instead, there is nothing showing
  3. I have been using cef_binary_89.0.17+ge7bbb1d+chromium-89.0.4389.114_windows64_client
  4. yes it is reproducible every time, I am using cef_binary_89.0.17+ge7bbb1d+chromium-89.0.4389.114_windows64_client
  5. On Google Chrome v90.0.4430.93 it is not reproducible.

Additional info: Of course it is for Polish language and keyboard polish (programmer) (polski programisty).

I would appreciate the help with this issue.

Regards,

Jakub

Comments (5)

  1. Marshall Greenblatt

    What Windows version are you using and what locale do you have configured?

    Can you test CEF at the same (v90) version? Does this work in any CEF version?

  2. Marshall Greenblatt

    Please also test each of the --enable-chrome-runtime and --use-views flags in v90 and report if it works correctly with either flag.

  3. Jakub reporter

    I am using Windows 10 pro v1809 build: 17763.1217 (x64).
    Locale Poland (pl-PL).

    Additionally i have tested on:
    - cef v43
    - cef v63
    - cef v86
    - cef v89
    - cef v90 (90.0.4430.93)
    and it does not work on any of the versions.
    I tried adding --enable-chrome-runtime and --use-views and still doesn’t work.

  4. Jakub reporter

    I have found a little bit of a solution:

    I was using it with a flag --off-screen-rendering-enabled but I guess this flag disables diacritics. After removing it, diacritics work fine.

  5. Log in to comment