Windows: Browser crash on Windows 11

Issue #3158 wontfix
Matthias Hoste created an issue

Hi,

I’m embedding Cef with CefSharp in my WPF application. This worked fine up until I switched to Windows 11 with .Net 6.
I’ve tried the sample application(https://bitbucket.org/chromiumembedded/cef/overview) but this one also crashes. Both crash with these messages in the debug.log file: https://pastebin.com/e6pzAd5c

Comments (3)

  1. Marshall Greenblatt

    What CEF version? What Windows 11 version? How does Google Chrome behave at the same version?

    What is the symbolized stack trace for the crash?

    From your log file, it looks like all sub-processes are crashing. Does it help if you run cefclient with --no-sandbox?

  2. Matthias Hoste reporter

    Thank you for your fast reply, sorry I totally forgot,
    My cef version is: CEF 91.1.21+g9dd45fe+chromium-91.0.4472.114 / Chromium 91.0.4472.114
    My Windows 11 build is: 22000.51
    I can’t seem to get a good stacktrace(I’m not experienced with native stacktraces) though x64dbg shows it calls back into cefclient.exe after cef.initialize initializes the sandbox. At least that what the function name told me, I’d post it here but I can’t seem to get it to recognize the symbols anymore. I’ll keep trying and post once I have it.
    Adding --no-sandbox does not solve the issue

  3. Marshall Greenblatt

    I suggest working with the CefSharp maintainers to debug your problem further. If it turns out to be a CEF issue then we can re-open @amaitland

  4. Log in to comment