Commits

matt chisholm committed d8c7dd5 Draft Merge with conflicts

Merge branch 'refs/heads/master' into python2.4-2.5

Conflicts:
python/pottymouth.py
python/tests.py

  • Participants
  • Parent commits 8f30a78, 85f2dc9
  • Branches default

Comments (0)

Files changed (5)

python/debian/changelog

+python-pottymouth (2.2.1-0) karmic; urgency=low
+
+  * removed support for Python 2.4 and 2.5
+  * fixed bug in setup.py
+
+ -- Matt Chisholm <matt@theory.org>  Sun, 09 Sep 2012 08:13:33 -0700
+
+python-pottymouth (2.1.4-0) karmic; urgency=low
+
+  * last version with Python 2.4 and 2.5 support
+
+ -- Matt Chisholm <matt@theory.org>  Sun, 09 Sep 2012 09:19:52 -0700
+
+python-pottymouth (2.1.3-0) karmic; urgency=low
+
+  * support indented blockquotes
+  * support port numbers in urls
+  * support file to parse on the command line
+  * show different EOF string on Windows
+
+ -- Matt Chisholm <matt@theory.org>  Mon, 12 Mar 2012 13:11:09 -0700
+
 python-pottymouth (2.1.2-0) karmic; urgency=low
 
   * lots of improvements and bug fixes

python/pottymouth.py

File contents unchanged.

python/setup.py

File contents unchanged.

python/tests.py

File contents unchanged.
 
       <h3 id="download">Download</h3>
 
-      <p>PottyMouth is licensed under the <a href="http://www.opensource.org/licenses/bsd-license.php">BSD License</a>. The Python implementation requires <a href="http://python.org/">Python</a>, version 2.4 or newer.</p>
+      <p>PottyMouth is licensed under the <a href="http://www.opensource.org/licenses/bsd-license.php">BSD License</a>. The Python implementation requires <a href="http://python.org/">Python</a>, version 2.6 or newer. The last version to support Python 2.4 and 2.5 was <a href="https://github.com/glyphobet/pottymouth/tree/2.1.2">2.1.2</a>.</p>
 
-      <p>You can check out the latest development version from <a href="http://bitbucket.org/glyphobet/pottymouth/">BitBucket</a> with <br />
-        <code>hg clone http://bitbucket.org/glyphobet/pottymouth/</code><br />
-        or from <a href="https://github.com/glyphobet/pottymouth">GitHub</a> with <br />
+      <p>You can check out the latest development version from <a href="https://github.com/glyphobet/pottymouth">GitHub</a> with <br />
         <code>git clone git://github.com/glyphobet/pottymouth.git</code>.
+        The <a href="http://bitbucket.org/glyphobet/pottymouth/">BitBucket</a> repository is obsolete as of version 2.2, don't use it.
+      </p>
 
-      <p>You can also download Python packages of the latest stable release, 2.1.3, released 12 March 2012:</p>
+      <p>You can also download Python packages of the latest stable release, 2.2.1, released 9 September 2012:</p>
 
       <ul>
         <li>From <a href="http://pypi.python.org/pypi/PottyMouth">pypi</a> with <code>easy_install pottymouth</code>.</li>
-        <li><a href="http://glyphobet.net/pottymouth/dist/PottyMouth-2.1.3-py2.7.egg">PottyMouth-2.1.3-py2.7.egg</a></li>
-        <li><a href="http://glyphobet.net/pottymouth/dist/PottyMouth-2.1.3.tar.gz">PottyMouth-2.1.3.tar.gz</a></li>
+        <li><a href="http://glyphobet.net/pottymouth/dist/PottyMouth-2.2.1-py2.7.egg">PottyMouth-2.2.1-py2.7.egg</a></li>
+        <li><a href="http://glyphobet.net/pottymouth/dist/PottyMouth-2.2.1.tar.gz">PottyMouth-2.2.1.tar.gz</a></li>
         <li><a href="http://glyphobet.net/pottymouth/dist/?C=M;O=D">older versions</a></li>
-        <li><a href="http://glyphobet.net/pottymouth/dist/python-pottymouth_2.1.3-0_all.deb">python-pottymouth_2.1.3-0_all.deb</a></li>
+        <li><a href="http://glyphobet.net/pottymouth/dist/python-pottymouth_2.2.1-0_all.deb">python-pottymouth_2.2.1-0_all.deb</a></li>
       </ul>
 
-      <p>You can also download the latest JavaScript implementation from <a href="http://bitbucket.org/glyphobet/pottymouth/">bitbucket.org</a>:</p>
+      <p>You can also download the latest JavaScript implementation from <a href="https://github.com/glyphobet/pottymouth/">github.com</a>:</p>
 
       <ul>
-        <li><a href="http://bitbucket.org/glyphobet/pottymouth/raw/tip/javascript/pottymouth.js">pottymouth.js</a>.</li>
+        <li><a href="https://raw.github.com/glyphobet/pottymouth/master/javascript/pottymouth.js">pottymouth.js</a>.</li>
       </ul>
 
-      <p>An experimental port of PottyMouth 1.0.2 to <a href="http://ruby-lang.org">Ruby 1.9.0</a> is also available:</p>
+      <p>An experimental (obsolete) port of PottyMouth 1.0.2 to <a href="http://ruby-lang.org">Ruby 1.9.0</a> is also available:</p>
 
       <ul>
         <li><a href="http://glyphobet.net/pottymouth/dist/PottyMouth-1.0.2.1.gem">PottyMouth-1.0.2.1.gem</a></li>
       </ul>
 
-      <p>If you have any suggestions or problems with PottyMouth, please feel free to email me at <tt>matt dash pottymouth at theory dot org</tt>.</p>
+      <p>If you have any suggestions or problems with PottyMouth, please feel free to email me at <tt>matt dash pottymouth at theory dot org</tt> or <a href="https://github.com/glyphobet/pottymouth/issues">create an issue on GitHub</a>.</p>
 
       <p>If you use PottyMouth and like it, please consider donating via Flattr:
         <a class="FlattrButton" style="display:none;" rev="flattr;button:compact;" href="http://glyphobet.net/pottymouth/"></a>