Commits

coady  committed c15cd61

PyLucene 3.1 deprecated.

  • Participants
  • Parent commits 738589b

Comments (0)

Files changed (4)

 Lupyne should run anywhere PyLucene does, though its primary testing is on the popular unix variants.
 
  * Python 2.6.6+, 2.7
- * PyLucene 3.1, 3.2, 3.3, 3.4, 3.5
+ * PyLucene 3.2, 3.3, 3.4, 3.5
  * CherryPy 3.1.2+, 3.2 (only required for server)
 
 Usage

File lupyne/engine/__init__.py

 from .spatial import PointField, PolygonField
 
 assert lucene.VERSION >= '3.1'
+if lucene.VERSION < '3.2':
+    warnings.warn('Support for lucene 3.1 will be removed in the next release.', DeprecationWarning)
 ==================
  * Engine:
    
+   - PyLucene 3.1 deprecated
    - Support for all IndexWriterConfig options
 
  * Server:

File test/remote.py

         assert result['facets'] == {'name': {'sample': 1}} and result['spellcheck'] == {}
         resource = client.Resource('localhost', self.ports[-1])
         assert set(resource.get('/').values()) < set([0, 1])
-        assert resource.post('/update', ['filters', 'sorters']) == 2
+        assert resource.post('/update', {'filters': True, 'sorters': True}) == 2
         assert resource.get('/docs') == [0, 1]
         with assertRaises(httplib.HTTPException, httplib.NOT_FOUND):
             resource.get('/docs/name/sample')