OSX 10.11 (El Capitan) Package Installation Failed

Issue #57 new
Elihu Bogan created an issue

Hi there, tried to run the .pkg file for 2.6.1 and got the following warning:

"This package is incompatible with this version of OS X and may fail to install."

After proceeding, I did indeed receive the message that this package failed to install.

Is there a different version I should be looking for? I've had the same problem while trying to install my old go-to PDFWriter for Mac (derived from this), and I'm assuming the root of the problem is the same).

Thanks!

Comments (8)

  1. kicin_

    Hi guys, do you think about some update? It's still not working on Sierra too, or some alternatives maybe? Thank you

  2. papabed

    Hi, did you find an issue to use with El Capitan or an alternative solution ? Somebody try to compile ? Thank you

  3. Bryan Foriest

    The failure from SIP is in writing the PPD file or creating a symlink in /usr/share/cups/model/ (this is a protected location). There are two solutions, and no need to turn off SIP.
    1) manually choose the PPD file from the Add Printer dialog (choose Use: other). 2) use the "-P" argument to specify the path to the PPD file when installing the printer using the lpadmin utility. This works very well from an installer.

  4. Brandon Payne

    Anyone care to make a pull request implementing Bryan's changes? BTW, what's the deal with brew install cups-pdf. Fails with:

    → brew install cups-pdf
    Error: No available formula with the name "cups-pdf"
    It was migrated from caskroom/cask to homebrew/core.
    
  5. devillartay

    Could not install cups-pdf under El Capitan so switched to PDFwritter. Be aware that it will not work right away. Need to follow the following procedure (obtained from https://support.farmerswife.com/support/solutions/articles/17000062134-pdf-printing-results-in-empty-or-zero-bytes-size-pdf): 2) After installing the PDFWriter package go back and explore the contents of the installer package, then open up the .gz archive. 3) Copy the "PDFWriter.ppd" file from the archive (Archive/Library/Printers/Lisanet/PDFwriter/) to your machine to this path: /Library/Printers/PPDs/Contents/Resources. 4) Now go to the Printers dialog and add the printer, choosing the Lisanet driver as explained in the documentation. IMPORTANT: If you add the printer in System Preferences before steps #1 and #2 PDFWriter will NOT work.

    Now it works fine and I can PDF write files from wine as before, Yes!!!!!

  6. Log in to comment