1. cogni
  2. mobiweaver
Issue #1 resolved

Collective Search help

Darren Bambrick
created an issue

Hi Pedro

Firstly, this is a brilliant package and will be extremely useful to me.

I have implemented your code into our Sap Ecc 6.0 System. I am having a strange problem with the collective search helps. If multiple records are returned from the collective search help then I get a JQ error stating "Error Loading Page", However, if a single record is returned then it works correctly. Elementary search helps work great.

I installed the code using saplink and hosted the js files on our server.

Then i downloaded the zip for .2 collective search helps and updated the code with saplink and also loaded the updated js files into the system.

Any ideas why this is happening ?

Many thanks

Darren

Comments (4)

  1. Pedro Lima

    Hi Darren,

    I had a busy week and could only check this today. I used your example for the carriers search help and it worked (I choose country PT and got several results). I tried with the version from the repository.

    Can you attach the xml from the search call that fails for you (for example open the inspector on chrome and get the results from the ajax call, or just use the url below and adapt for the parameters you used).

    /sap/bc/bsp/sap/ymwsearchhelp/search.do?sh=F4_LFA1_FRTGP&LIFNR=&LAND1=PT&NAME1=&ORT01=&PSTLZ=&REGIO=&SFRGR=

    //pedro

  2. Log in to comment