Can't install on windows

Issue #183 new
Michaël BROUTIN created an issue

Hi,

I tried installing kallithea on windows with the instructions here : http://docs.kallithea-scm.org/en/latest/installation_win.html

It fails at the "pip install kallithea" step, with a sandboxViolation :

(Env) C:\Kallithea\Env\Scripts>pip install kallithea
Collecting kallithea
  Using cached Kallithea-0.3.tar.gz
    Complete output from command python setup.py egg_info:
    warning: no previously-included files matching '*' found under directory 'do
cs\_build\_sources'
    warning: no files found matching '*.html' under directory 'docs\_build'
    Warning: no news for this version found
    Traceback (most recent call last):
      File "<string>", line 20, in <module>
      File "c:\users\pb19579\appdata\local\temp\2\pip-build-ae4vc6\kallithea\set
up.py", line 190, in <module>
        """,
      File "c:\produits\python27\Lib\distutils\core.py", line 111, in setup
        _setup_distribution = dist = klass(attrs)
      File "c:\kallithea\env\lib\site-packages\setuptools\dist.py", line 268, in
 __init__
        self.fetch_build_eggs(attrs['setup_requires'])
      File "c:\kallithea\env\lib\site-packages\setuptools\dist.py", line 312, in
 fetch_build_eggs
        replace_conflicting=True,
      File "c:\kallithea\env\lib\site-packages\pkg_resources\__init__.py", line
846, in resolve
        dist = best[req.key] = env.best_match(req, ws, installer)
      File "c:\kallithea\env\lib\site-packages\pkg_resources\__init__.py", line
1091, in best_match
        return self.obtain(req, installer)
      File "c:\kallithea\env\lib\site-packages\pkg_resources\__init__.py", line
1103, in obtain
        return installer(requirement)
      File "c:\kallithea\env\lib\site-packages\setuptools\dist.py", line 379, in
 fetch_build_egg
        return cmd.easy_install(req)
      File "c:\kallithea\env\lib\site-packages\setuptools\command\easy_install.p
y", line 639, in easy_install
        return self.install_item(spec, dist.location, tmpdir, deps)
      File "c:\kallithea\env\lib\site-packages\setuptools\command\easy_install.p
y", line 669, in install_item
        dists = self.install_eggs(spec, download, tmpdir)
      File "c:\kallithea\env\lib\site-packages\setuptools\command\easy_install.p
y", line 852, in install_eggs
        return self.build_and_install(setup_script, setup_base)
      File "c:\kallithea\env\lib\site-packages\setuptools\command\easy_install.p
y", line 1080, in build_and_install
        self.run_setup(setup_script, setup_base, args)
      File "c:\kallithea\env\lib\site-packages\setuptools\command\easy_install.p
y", line 1068, in run_setup
        raise DistutilsError("Setup script exited with %s" % (v.args[0],))
    distutils.errors.DistutilsError: Setup script exited with error: Setup scrip
t exited with error: Setup script exited with error: Setup script exited with er
ror: SandboxViolation: open('build\\bdist.win-amd64\\egg\\paste\\evalexception\\
media\\MochiKit.packed.js', 'wb') {}

    The package setup script has attempted to modify files on your system
    that are not within the EasyInstall build area, and has been aborted.

    This package cannot be safely installed by EasyInstall, and may not
    support alternate installation locations even if you run its setup
    script by hand.  Please inform the package's author and the EasyInstall
    maintainers to find out if a fix or workaround is available.

    ----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in c:\users\pb19579\
appdata\local\temp\2\pip-build-ae4vc6\kallithea

Some context : - Installed on a fresh win2012 install, x64 - Used python 2.7.11

Thanks

Comments (5)

  1. Mads Kiilerich

    Weird. Kallithea doesn't use MockiKit directly. It is the dependency "paste" that fails. You can perhaps reproduce without Kallithea with "pip install Paste==2.0.2".

    Can you also try with Python 2.7.10?

  2. Michaël BROUTIN reporter

    I just tried "pip install Paste==2.0.2" and it worked, then I tried again "pip install kallithea" and it seems to install correctly... (will update this issue when install is complete).

    I must say that before typing those commands, I started installing RhodeCode on the computer (since I am migrating from Rhodecode installed elsewhere anyway). Maybe some common dependencies got installed and fixed the problem?

    I can try to reproduce if you like but I'm not sure how to get back to a clean environnement... uninstalling rhodecode, python and kallithea maybe?

  3. Michaël BROUTIN reporter

    Also, some extra info : I'm accessing the Internet through a company proxy and maybe it failed downloading some package at some point...

  4. Michaël BROUTIN reporter

    Okay, the rest of the installation process went on smoothly and I can now serve it

  5. Michaël BROUTIN reporter

    A little follow up on the subject : after removing python 2.7.11, installing 2.7.10 instead, I could re-install Kallithea from scratch without running into this problem anymore.

  6. Log in to comment