HTTPS + Git Clone = 405 error

Issue #234 resolved
zwarmapapa created an issue

I've recently bought a SSL certificate.

I got Kallithea to work with it by using PASTE instead of WAITRESS, and by supplying PASTE with the SSL certificate.

Everything works fine, except for git clone. Whenever I git clone, I get this error message:

error: The requested URL returned error: 405 while accessing https://username:password@mydomain.com:5000/repository/info/refs

I've tried going to the /info/refs path in the browser, and when I do that, I get an access popup (like a .htaccess login popup). Logging into it with my Kallithea username/password fails.

Again, everything else works fine, like git fetch, git push, browsing in the web interface, etc. It's just that git clone doesn't work.

The changes I've made to my config:

 ## PASTE ##
use = egg:Paste#http
threadpool_workers = 5
threadpool_max_requests = 10
use_threadpool = true
ssl_pem = /etc/myssl/certall.pem

 ## WAITRESS ##
 #use = egg:waitress#main
 #threads = 5
 #max_request_body_size = 107374182400
 #asyncore_use_poll = True

force_https = true # tried false as well, didn't make a difference to git clone

Comments (8)

  1. Mads Kiilerich

    Hmm ... it sounds unlikely that this should be a bug in Kallithea. It sounds more like something in your custom paste setup. I once got it working as a proof of concept but forgot all details again ... and I doubt I tested git.

    Few people are using Kallithea with https on the Python web servers. I suggest using apache with mod_wsgi. That is a well tested and quite common setup. Once you have a working reference, you can perhaps figure out what is wrong in the paste setup.

  2. zwarmapapa reporter

    Awesome, it works perfectly with a proxy pass.

    I've changed the port of Kallithea from 5000 to 6002 (6000 and 6001 were already in use in my case), then I've added a virtual host with port 5000 that uses SSL and has a proxy pass to port 6002.

    Now Kallithea works the exact same as before, except that it now uses https instead of http.

    Thanks.

  3. zwarmapapa reporter

    With Paste and SSL you mean? I have no idea. All I know is that path-to-repo/info/refs gives a 405 when using Paste and SSL. With Waitress and a proxy pass it works fine.

  4. Log in to comment