Issue #326 resolved
刘科彬 created an issue

MySQL 7

Warning: '@@tx_isolation' is deprecated and will be removed in a future release. Please use '@@transaction_isolation' instead

Comments (3)

  1. Thomas De Schampheleire

    Hello, welcome to Kallithea and thanks for reporting.

    The issue seems to be that sqlalchemy is using a construct 'tx_isolation' which recent versions MySQL is warning about. Later versions of SQLAlchemy have solved this problem with a version check. The minimum version you need of SQLAlchemy is 1.1.15 (see http://docs.sqlalchemy.org/en/latest/changelog/changelog_11.html#change-364804fd47128c29140cfd2c6f8b8063)

    On the default branch of Kallithea, the version of SQLAlchemy is already more recent and turned into a range rather than a fixed version:

    "SQLAlchemy>=1.1,<1.2",
    

    compared to the version in the latest release ('stable' branch of Kallithea):

    "SQLAlchemy==0.7.10",
    

    I checked and the relevant commits that changed this line do not indicate other required code changes to support this newer SQLAlchemy version. You should thus be able to change setup.py manually and upgrade SQLAlchemy. These relevant commits are:

    So, your options are:

    • ignore the warning for now, everything still works fine
    • manually upgrade sqlalchemy to 1.1.15 or a more recent version in 1.1.x range
    • upgrade to the default branch of Kallithea, which is going to become a new major release in the future. For the 'stable' branch, we are not planning new releases to fix this issue.
  2. Log in to comment