Inconsistent upload of recordings to Owncloud

Issue #2834 resolved
Former user created an issue

ACR 30.0 running on a Samsung Galaxy S6, using Android 7.0.

I have ACR configured to upload to my private Owncloud server, only over WiFi, using WebDAV. The Owncloud server is on my internal LAN, and is also accessible via the Internet.

While searching for some particularly important calls today, I found that they weren't on Owncloud. They were available on the mobile. In fact, a call that I made today is the same - not in Owncloud, but is on Mobile. I made the call many hours ago and the device has been on WiFi the whole time. I can manually upload the call from within ACR if I use the "share" icon and choose the Owncloud app.

A look over the past year shows about 760 calls on my mobile, but only about 430 have successfully been uploaded to Owncloud.

ACR shows no uploads pending.

WebDAV upload is the sole reason I purchased a license.

Any ideas?

Comments (3)

  1. David Grabowski

    So... I think I fixed it, and it has nothing to do with ACR.

    My Owncloud server is sitting behind an apache server running mod_proxy.

    I tried 'upload again' in ACR, and then noticed that the upload would fail at some point. The failures would occur with errors in the apache logs.

    [Sat Dec 08 00:44:47 2018] [error] [client 192.168.1.117] (20014)Internal error: proxy: error reading status line from remote server (ip of my server) [Sat Dec 08 00:44:47 2018] [error] [client 192.168.1.117] proxy: Error reading from remote server returned by /owncloud/remote.php/dav/files/callrec/ACRRecordings/(file where it barfed)

    No further uploads would occur.

    By setting the 'proxy-initial-not-pooled' environment variable in apache, it looks like the issue is no longer happening.

    HOWEVER - ACR needs to do a better job of recovering from this. i.e., if an upload fails, ACR should leave the file in the 'pending uploads' area, and shouldn't simply ignore the upload completely. So, this is still a bug.

  2. copluk repo owner

    ACR might have interpreted the error as permanent error. You can change Advanced cloud settings to make sure it does not disconnect from the service even if it thinks problem is permanent

  3. Log in to comment