Bootstrap 2.0.3.r329 not working with Yii 1.1.13

Create issue
Issue #217 new
Former user created an issue

I've downloaded the latest version of bootstrap (2.0.3.r329) and Yii Framework (1.1.13) and have problems with the Boostrap extension. (No problems with previous versions).

I've created a completely new Yii project and followed the new setup instructions linked from http://www.yiiframework.com/extension/bootstrap. If I just change the default menu to use TBNavbar, no menu appears! Looking at the page source, no includes exist for any bootstrap CSS or JavaScript files. Further research found other developers with similar problems (see post #829 at http://www.yiiframework.com/forum/index.php/topic/23982-extension-bootstrap/pagest820). Issue #196 suggests a temporary fix, but TBNavBar still produces no menu (haven't tested other controls).

For the time being, we're rolling back to a previous version of bootstrap.

Comments (2)

  1. Nikola Kovacs

    Call Yii::app()->bootstrap->register() in the layouts or views where you want to use bootstrap. That pulls in the base css and js

  2. Log in to comment