ControlsDemo test on different Linux systems

Issue #130 open
Zoltan Karpati created an issue

I would like to inform you that I have tested my program and the official ControlsDemo on the following Linux systems (under VMware Workstation):

It worked fine on the following 180 Linux distros: AcademiX GNU/Linux 2.4; Accessible-Coconut 20.04.02; Alien-OS LTS 09. Juni 2019; AllegianceOS 3.0; ALT Linux 8.2; Antergos 17.11.; antiX 17.2; ArchBang Linux Winter 0112; Archman KDE Plasma 2019.02; ArcoLinux v18.11.2; Argent KDE Plasma 1.5.2; Artix Linux LXQT 2018.10.13; AryaLinux 1.0 XFCE; Asril OS 7.0 Lare; Astra Linux Common Edition 2.12.13; AUSTRUMI 3.9.0; Auxtral 2.5 Cinnamon GNU/Linux; AV Linux (2018.06.25); B2D Desktop 2019 V1.0.5 XFCE; BackBox Linux 5.2; BEE free MMXX; Berry Linux 1.30; BigLinux 7.10; Bionicpup64 8.0 CE; BlackArch Linux 2018.12.01; Black Lab Enterprise Linux 8; blackPanther OS v18.1; BlackWeb 1.2; BlankOn 11.0.1; Bluestar Linux 4.19.2; Bodhi Linux 5.0.0; BunsenLabs Linux Helium; CAELinux 2018; CAINE 10.0; Calculate Linux 18; Canaima GNU/Linux 6.1 Kavak; CentOS 7; ChaletOS 16.04.2; Chakra GNU/Linux 2019.01 (GTK 3 install: use the Octopi application); CloverOS GNU/Linux 2019.07.19; Condres OS 2019.03 Gnome Edition; Debian 9.1; Deepin 15.4.1; Devuan 2.0.0 ASCII; Drauger OS 7.4.1; DRBL Live 2.6.2-1; DuZeru; EasyOS 1.0.8; EndeavourOS 2019.07.15; Endless OS 3.5; ExTiX 19.0; EducatuX 9.8; Emmabuntüs DE3 1.0; Enso 0.3.1; ETi-pup 5.1.6; Exe GNU/Linux ASCII 20190714; Expirion Linux 3.0; Exton|OS v190521; Fatdog64 Linux 800 (GTK 3 install: use the gslapt application); Fedora 26; Fenix OS; Feren OS (July 2018); Freespire 4.5.; Garuda Linux 200831; GeckoLinux Static Plasma; Gentoo Linux 2016.07.04; Greenie Linux; Grml 2018.12; GoboLinux 016.01; Gorizont Linux 2.0.2; Hamara Sugam 2.1; Hanthana Linux 30; HefftorLinux XFCE v20.8.30; HexagonOS 1.0; Ignis OS 5.0; Kali Linux 2017.2; Kanotix Steelfire KDE; KaOS 2018.01 (GTK 3 install: use the Octopi application); Karoshi 7.0; KDE neon; Kubuntu 18.10; KXStudio 14.04.5; Linspire 8.0 RC1; Linuxfx 10 WX; Linux Kodachi 5.2; Linux Lite 4.2; Linux Mint 18.1; LinuxSchools Client V6.1; Live Raizo; LoopLinux v21.02.3; Lubuntu 17.10; LuninuX OS 17.04; LXLE Linux 16.04.4; Mabox Linux 21.02; Mageia 6.1; MakuluLinux 15 Flash Edition; Manjaro Linux 17.0; Maui Linux 17.06; MAX: Madrid_Linux 10.0; MAZON OS 1.4.3.l; MorpheusArch Linux 2018.4; MX Linux 17.1; Namib GNU/Linux Budgie 18.08; Neptune 5.6; Netrunner 19.08 – Indigo; Network Security Toolkit 30-11210; Nova 6.0; NuTyX MATE 10.4; Onix OS 1.7; OpenMandriva Lx 3.0; openSUSE Leap 42.2; Oracle Linux 7.6; OSGeoLive 12.0; PakOS 2020-04-18; Pardus 17.4 XFCE; Parrot Studio 3.8; PCLinuxOS 2017.07; Peach OSI 16.04 TW; Pearl Linux MATE 7.0; PelicanHPC GNU Linux 4.1 XFCE; Pentoo 2018.0; Peppermint 9; Pinguy OS 18.04.1; Pisi Linux 2.1 ATA; Pixel OS 2.0 “Bart&”; Plop Linux 4.3.9; Pop!_OS 18.10; Porteus 4.0 MATE; Poseidon Linux 9 MB2315; Q4OS 2.6 Scorpion; Quibian OS 2.0; Rebellin Linux 3.5 Gnome; RebornOS 2020.08.19; Redcore Linux Hardened 1806; Red Hat Enterprise Linux 7; Refracta 8.3; Regolith Linux 1.2; Resilient Linux 1.0; Robolinux Cinnamon 10.3; ROSA Fresh KDE R10; Roshan OS 1.0; Runtu LITE 18.04; Sabayon Linux 18.05 GNOME Edition; SalentOS 2.0; Salient OS v20.07; Salix Xfce 14.2; Scientific Linux 7.4; SELKS 4.0; Septor-2019; SharkLinux 4.15.0-39; siduction 18.3.0 XFCE; Simplicity Linux 19.10; Slax 9.8.0 (GTK 3 install: from terminal: sudo apt-get install libgtk3.0); Slackel 7.1; Slontoo 18.07.1 MATE; Solus 3 GNOME; SolydXK 201902; SparkyLinux 4.9; Star Kirk 2.1.0; Storm OS 2021.01.17; SuliX Professional 8; SuperX 5.0; SwagArch GNU/Linux 18.12; T2 SDE 20.10; Tails 3.10.1; Trisquel 8.0 LTS Flidas; Tsurugi Linux Lab 2018.1; Ubuntu 16.10; Ubuntu Budgie 18.04.1; Ubuntu MATE 18.04.1; Ubuntu Kylin 19.04; Ubuntu Studio 18.10; Ufficio Zero 1.0; Ultimate Edition 5.0; Uruk GNU/Linux 2.0 XFCE; Void Linux MATE (2018.11.11.); Voyager 18.04 LTS; Xubuntu 18.04; Zentyal Server 6.1.; Zorin OS 12.1 Core

Can anyone test it on other Linux distros and share the result?

Comments (61)

  1. Zoltan Karpati reporter
    • edited description

    It did not work correctly on Fedora 26.

    It is possible to fix the problems on the Elementary OS 0.4.1; Fedora 26; Gentoo Linux systems?

  2. Eugene Kryukov repo owner

    We will try do our tests, and also will make a research about using of linux dists. We certainly don't have plan to support exotic (or not stable like Elementary 0.4.x).

  3. Zoltan Karpati reporter

    I can select the File and Help and its menupoints, but I can't select the TabControl's Tabitems (Standard, Addicional, etc...) by mouse. I can't select the component on the Standard Tabitem by mouse.

  4. Zoltan Karpati reporter

    One thing is maybe different in our development systems: the used Linux SDK. I am using the Ubuntu 16.10 SDK. I have uploaded my ControlsDemo executable to my web page (without the file): Can you test it on your Linux system?

    Can you tell which SDK are you using? Can you send me ( your ControlsDemo executable to test it in my Linux systems?

  5. Zoltan Karpati reporter

    I did try your ControlsDemo version, but the problem is the same as I reported:

    I can select the File and Help and its menupoints, but I can't select the TabControl's Tabitems (Standard, Addicional, etc...) by mouse. I can't select (use) the components on the Standard Tabitem by mouse.

    Did you try my build on your Fedora?

  6. Zoltan Karpati reporter

    Thank you for your testing, but I don't understand the issues absolutely.

    Can you tell which Linux SDK are you using in your Rad Studio?

    Are you tested it on real Linux PC or using VMWare only?

  7. Eugene Kryukov repo owner

    We use Ubuntu 16.04 sdk. The main reason of difference maybe is because we use Linux inside Parallels Desktop - it support GPU and all OpenGL stuff installed by default. I'm not sure about VMWare.

  8. Zoltan Karpati reporter

    Thank you for your information.

    I will try to create a bootable Fedora 26 USB pendrive (live DVD) to test it in a real PC. I will report you the result.

    Is is important which SDK I must use?

  9. Zoltan Karpati reporter

    I did create a bootable Fedora 26 USB pendrive (live DVD) to test it in a real PC. After it I tested it on different PCs, but the result was the same.

    I can select the File and Help and its menupoints, but I can't select the TabControl's Tabitems (Standard, Addicional, etc...) by mouse on its position. I can't select (use) the components on the Standard Tabitem on its position, but sometimes I can use the component, if I click above the component (about 1.5-2 cm).

  10. Eugene Kryukov repo owner

    Eventually we be able to reproduce this bug on Fedora 26 inside VMWare. We are working on it.

  11. Zoltan Karpati reporter

    If it will work on Fedora, I think it will work on Elementary OS 0.4.1 and Gentoo Linux also.

    (I can't imagine how works it on your Parallels Desktop correctly.)

  12. Eugene Kryukov repo owner

    Ok, eventually we found a reason why it works different and it seems it is not so easy to fix all of issues. It happens when Linux uses Wayland display - I've checked this and it is correct than on VMWare wayland is active, but on Parallels regular X11 server is used. The main Wayland limitation is that it is not support global coordinates and this bring lot of issues. The painting is easy to fix, but the other requires some time. We are working on it.

  13. Zoltan Karpati reporter

    Thank you for your investigation on this problem. I sent my answer to your PM via e-mail.

  14. Eugene Kryukov repo owner

    Runtime error 217 - Unhandled exception. Do you have any other log info ? Try to launch application without debug and check PAServer log

  15. Zoltan Karpati reporter

    After running paserver on KNOPPIX 8.1 I got the following error message:

    Error while loading shared libraries: cannot open shared object file: No such file or directory

  16. 天之狭霧

    Hi. I installed RHEL 7 and CentOS 7 in VirtualBox and debugged, but an error occurs.

    symbol lookup error: undefined symbol: gdk_broadway_display_get_type

    It works properly in your test, but what is missing for me?

  17. Zoltan Karpati reporter

    I did try to run it on Solus 3 GNOME (

    Can you tell me how to fix the following error message? symbol lookup error: undefined symbol: gdk_broadway_display_get_type

    I did try the following commands, but none of them worked for me in the terminal window (I am not a Linux Guru): (I got the "sudo: apt-get: command not found" error message)

    sudo apt-get install gtk2.0 (or) sudo apt-get install gtk3.0 (or) sudo apt-get install libgtk-3-dev

  18. Mathieu

    I tried to launch a simple FMX program on Fedora 27 and it does not work, error msg: segmentation fault (core dump).

    gdb backtrace:

    Missing separate debuginfos, use: dnf debuginfo-install glibc-2.26-15.fc27.x86_64
    [Thread debugging using libthread_db enabled]
    Using host libthread_db library "/lib64/".
    Program received signal SIGSEGV, Segmentation fault.
    0x00007ffff79374bc in _dl_catch_error () from /lib64/
    Missing separate debuginfos, use: dnf debuginfo-install at-spi2-atk-2.26.0-1.fc27.x86_64 at-spi2-core-2.26.0-1.fc27.x86_64 atk-2.26.0-1.fc27.x86_64 bzip2-libs-1.0.6-24.fc27.x86_64 cairo-1.15.8-1.fc27.x86_64 cairo-gobject-1.15.8-1.fc27.x86_64 dbus-libs-1.11.20-1.fc27.x86_64 expat-2.2.4-1.fc27.x86_64 fontconfig-2.12.6-3.fc27.x86_64 freetype-2.8-6.fc27.x86_64 gdk-pixbuf2-2.36.11-1.fc27.x86_64 glib2-2.54.1-1.fc27.x86_64 graphite2-1.3.10-3.fc27.x86_64 gstreamer1-1.12.3-1.fc27.x86_64 gstreamer1-plugins-base-1.12.3-1.fc27.x86_64 gtk3-3.22.26-2.fc27.x86_64 harfbuzz-1.4.8-1.fc27.x86_64 libX11-1.6.5-4.fc27.x86_64 libXau-1.0.8-9.fc27.x86_64 libXcomposite-0.4.4-11.fc27.x86_64 libXcursor-1.1.14-10.fc27.x86_64 libXdamage-1.1.4-11.fc27.x86_64 libXext-1.3.3-7.fc27.x86_64 libXfixes-5.0.3-4.fc27.x86_64 libXi-1.7.9-4.fc27.x86_64 libXinerama-1.1.3-9.fc27.x86_64 libXrandr-1.5.1-4.fc27.x86_64 libXrender-0.9.10-4.fc27.x86_64 libXtst-1.2.3-4.fc27.x86_64 libblkid-2.30.2-1.fc27.x86_64 libdatrie-0.2.9-6.fc27.x86_64 libepoxy-1.4.3-3.fc27.x86_64 libffi-3.1-14.fc27.x86_64 libgcc-7.2.1-2.fc27.x86_64 libgcrypt-1.8.1-1.fc27.x86_64 libgpg-error-1.27-3.fc27.x86_64 libicu-57.1-8.fc27.x86_64 libicu-devel-57.1-8.fc27.x86_64 libmount-2.30.2-1.fc27.x86_64 libpng-1.6.31-1.fc27.x86_64 libselinux-2.7-2.fc27.x86_64 libstdc++-7.2.1-2.fc27.x86_64 libthai-0.1.25-4.fc27.x86_64 libuuid-2.30.2-1.fc27.x86_64 libwayland-client-1.14.0-1.fc27.x86_64 libwayland-cursor-1.14.0-1.fc27.x86_64 libxcb-1.12-5.fc27.x86_64 libxkbcommon-0.7.1-5.fc27.x86_64 libxkbcommon-x11-0.7.1-5.fc27.x86_64 lz4-libs-1.8.0-1.fc27.x86_64 mesa-libwayland-egl-17.2.2-4.fc27.x86_64 pango-1.40.12-1.fc27.x86_64 pcre-8.41-1.fc27.2.x86_64 pcre2-10.30-1.fc27.x86_64 pixman-0.34.0-4.fc27.x86_64 systemd-libs-234-8.fc27.x86_64 xz-libs-5.2.3-4.fc27.x86_64 zlib-1.2.11-4.fc27.x86_64
    (gdb) bt
    #0  0x00007ffff79374bc in _dl_catch_error () at /lib64/
    #1  0x00007ffff75d6715 in _dlerror_run () at /lib64/
    #2  0x00007ffff75d6021 in dlopen@@GLIBC_2.2.5 () at /lib64/
    #3  0x00007fffeda9418b in  ()
        at /home/a/PAServer/scratch-dir/Admin-fedora/Project2Linux/
    #4  0x0000000000000018 in  ()
    #5  0x00007fffeda5039b in  ()
        at /home/a/PAServer/scratch-dir/Admin-fedora/Project2Linux/
    #6  0x00000000010b7260 in  ()
    #7  0x00007fffeda5bad3 in  ()
        at /home/a/PAServer/scratch-dir/Admin-fedora/Project2Linux/
    #8  0x00007fffedd90940 in  ()
        at /home/a/PAServer/scratch-dir/Admin-fedora/Project2Linux/
    #9  0x00007fffeda4cd6c in  ()
        at /home/a/PAServer/scratch-dir/Admin-fedora/Project2Linux/
    #10 0x00007fffffffdf48 in  ()
    #11 0x00007fffffffdf38 in  ()
    #12 0x00007fffede768a0 in  ()
        at /home/a/PAServer/scratch-dir/Admin-fedora/Project2Linux/
    #13 0x00007fffeda4cdbe in  ()
        at /home/a/PAServer/scratch-dir/Admin-fedora/Project2Linux/
    #14 0x00007fffffffdf38 in  ()
    #15 0x00007fffeda363c9 in  ()
    ---Type <return> to continue

    The simple program is a newly created fmx project with a form with no button. It works on stretch and centos7. So I don't think the ControlsDemo will work either on Fedora 27.

  19. Mathieu


    Your ControlsDemo and i3DConverter works on fedora 27.


    Indeed, on the 1.23 a dummy fmx project now works ok on my fedora 27.

    Thanks for your support.

  20. Eugene Kryukov repo owner

    Thank you for the report, it looks like our hosting provider restore our web site from old backup. Now site is up to date.

  21. Zoltan Karpati reporter

    Yes, I rebuild my app and the ControlsDemo.

    Error loading cannot open shared object file...... Runtime Error 217

  22. Zoltan Karpati reporter

    V1.32 FmxLinux runtime now embbeded to executable and deployed at launch

    I thought it resolves the Runtime error 217.

    I have recompiled and ran the my app and the ControlsDemo program on the KaOS 2018.01 using the v1.32 FMXLinux.

    The terminal window says:

    FMX Linux requires Runtime error 217 at <xx memory address>

  23. Eugene Kryukov repo owner

    I thought it resolves the Runtime error 217.

    No embedding doesn't mean that all runtime is linked statically now. We just embed as resource and on first launch it deployed to ~/.fmxlinux folder. Next time it just use it. It is mostly to easy deploying of application.

  24. Harry Stahl

    What will happen, when we update the executable application-file with a newer integrated Will the old version of automatically overwritten?

  25. Zoltan Karpati reporter


    It is a good question, because the v1.32 version creates a file in the ~/.fmxlinux folder.

  26. Eugene Kryukov repo owner

    Yeah, each version added version to the runtime lib name. In this case you can have few apps which is uses different FmxLinux and works simultaneously.

  27. Zoltan Karpati reporter

    It works on Calculate Linux 18 ( ) with a small problem.

    If I run the ControlsDemo and I move or resize a little bit the Form it works fine, otherwise I must click above the component (about 2 cm) to select (use) a component.

  28. Zoltan Karpati reporter
    • edited description

    I have removed the KNOPPIX distro from the incompatibility list, because it does not fit the minimal requirements of the FMXLinux.

    The creator of the KNOPPIX told me if I run the KNOPPIX on a 64 bit PC, it gives a 32 bit user space only.

  29. Zoltan Karpati reporter
    • edited description

    I have removed the GALPon MiniNo Queiles 3.1 distro from the incompatibility list, because it does not fit the minimal requirements of the FMXLinux.

  30. Zoltan Karpati reporter
    • edited description

    It works correctly on Canaima GNU/Linux 6.1 Kavak, HefftorLinux XFCE v20.8.30, LoopLinux v21.02.3, Mabox Linux 21.02, PakOS 2020-04-18, Roshan OS 1.0, Salient OS v20.07, Storm OS 2021.01.17

  31. Log in to comment