Commits

Lisandro Dalcin committed f3e1a4e

Require petsc4py>=3.4

Comments (0)

Files changed (1)

     if ('setuptools' in sys.modules):
         from os.path import exists, join
         metadata['zip_safe'] = False
-        metadata['install_requires'] = ['petsc4py>=3.3.1']
+        metadata['install_requires'] = ['petsc4py>=3.4']
         if not exists(join('src', 'tao4py.TAO.c')):
             metadata['install_requires'] += ['Cython>='+CYTHON]
         TAO_DIR = os.environ.get('TAO_DIR')
         if not (TAO_DIR and os.path.isdir(TAO_DIR)):
-            metadata['install_requires'].append('tao>=2.1,<2.2')
+            metadata['install_requires'].append('tao>=2.2,<2.3')
     #
     setup(packages     = ['tao4py',
                           'tao4py.lib',],