Boto Compatibility

Issue #204 resolved
danielgtaylor created an issue

I am one of the maintainers of Boto. As mentioned in #155, a few weeks ago we began to merge backward-compatible Python 3.3 and 3.4 support into our develop branch. Most modules now support Python 3 with passing unit and integration tests, and I am hoping to do a release soon. I am reaching out to you to ask if you would test our develop branch with Django Storages.

Testing against Python 2.x will help to ensure that we don't accidentally break third party modules like Django Storages. If you would like, you may also try out the Python 3 support and let us know any feedback. More information about the Python 3 support can be found in this boto-users post:

https://groups.google.com/forum/#!topic/boto-users/vcvoy8zrfP8

I appreciate any time that you can put into helping the Boto project with this.

Comments (3)

  1. danielgtaylor reporter

    I've done a simple test with Django 1.6, Python 2.7 and Boto from develop and things seem to work with the s3boto backend for a simple file uploader.

    If anybody with more experience with this project could do additional testing I would appreciate it.

  2. Log in to comment