Issue #9 new

Postgresql support in debian

Anonymous created an issue

To install ossec with Postgresql support, you need the packages postgresql-XX and postgresql-server-dev-XX. The last one is specifically necessary since it contains the pg_config binary, used by /src/os_dbd/dbmake.sh to check for postgresql's installation.

This script should have a verbose mode stating what exactly is missing since several distros package their binaries differently or this should be documented somewhere on ossec's wiki, maybe in a distro specific part of the documentation.

Comments (3)

  1. Anonymous

    Attached is the package list currently installed in my system.

    dpkg --list | grep postg ii postgresql 8.4.7-0squeeze2 object-relational SQL database (supported version) ii postgresql-8.4 8.4.7-0squeeze2 object-relational SQL database, version 8.4 server ii postgresql-client-8.4 8.4.7-0squeeze2 front-end programs for PostgreSQL 8.4 ii postgresql-client-common 113 manager for multiple PostgreSQL client versions ii postgresql-common 113 PostgreSQL database-cluster manager ii postgresql-server-dev-8.4 8.4.7-0squeeze2 development files for PostgreSQL 8.4 server-side programming

  2. Anonymous

    Same list, formated

    dpkg --list | grep postg

    postgresql 8.4.7-0squeeze2 object-relational SQL database (supported version)

    postgresql-8.4 8.4.7-0squeeze2 object-relational SQL database, version 8.4 server

    postgresql-client-8.4 8.4.7-0squeeze2 front-end programs for PostgreSQL 8.4

    postgresql-client-common 113 manager for multiple PostgreSQL client versions

    postgresql-common 113 PostgreSQL database-cluster manager

    postgresql-server-dev-8.4 8.4.7-0squeeze2 development files for PostgreSQL 8.4 server-side programming

  3. Log in to comment