An exception occurred during a WebClient request

Issue #26 resolved
created an issue

I tried to synchronize a currently open database with a one in dropbox and it threw me the following error.


dropbox://KP/db.kdbx (KeeCloud Dropbox credentials)

An exception occurred during a WebClient request.

This property is not implemented by this class.


I did set the username to the title of an entry in the same database that has the dropbox username and password. Just to let you know, I did use the URL credentials wizard to get an username and password.

The same error occurs when I try to open a database in dropbox.

Comments (23)

  1. lvuser reporter

    OS: Windows 7 x64 Enterprise

    Keepass version: 2.23

    Keecloud version: 1.0.37

    I am not sure how to check which version of .Net keepass is using but the machine has the following versions of .Net framework installed.

    • v4.0.30319
    • v3.5
    • v3.0
    • v2.0.50727
    • v1.1.4322
    • v1.0.3705

    I hope this information helps you. Let me know if you want me to check anything else.

  2. infide1

    same, thing, started happening all of a sudden on all (2) my pc. No changes. Something must have changed in dropbox. windows 7 64bit ultimate keecloud 1.0.37 keepass2.25

  3. Rob Mahn

    This problem started for me today after trying to save from a very slow internet connection. The file was deleted from DropBox. I tried restarting KeePass to no avail. Then I went to Tools, Plugins, then cleared the cache and restarted KeePass. I also manually placed my file on DropBox. I should have only done one thing at a time to see what worked, but this did fix the problem.

  4. Anthony Serna

    Happens for me too. Only in Linux. Any Linux distro I try, really. been happening for months.

    For something to test against, ubuntu 14.04 x64, install mono-complete from repos, install keecloud. I tried accessing a .kdbx file located in a subfolder in my Dropbox.

  5. Anonymous


    The ProviderWebRequest properties: ConnectionGroupName, Timeout, and Proxy are throwing Not Implemented exceptions at System.Net.WebRequest.Create(Uri requestUri, Boolean useUriBase) at System.Net.WebClient.GetWebRequest(Uri address) at KeePassLib.Serialization.IOWebClient.GetWebRequest(Uri address) in KeePassLib\Serialization\IOConnection.cs:line 47 at System.Net.WebClient.OpenRead(Uri address)

    Adding default overrides shown below looks to fix this issue.

    public class ProviderWebRequest : WebRequest
        public override string ConnectionGroupName { get; set; }
        public override int Timeout { get; set; }
        public override IWebProxy Proxy { get; set; }
  6. Jim Keir

    I was having this for a long time too. I fixed it today with some manual repairs to the Dropbox side. It turns out that, at some point in the past, the sync must have failed because there was a "Database.kdbx.tmp" file but no "Database.kdbx". Renaming the .tmp file back to "Database.kdbx.tmp" fixed the problem.

    The same error occurs if there is no "Database.kdbx" file so it looks as though the plugin can't deal with creating the Dropbox copy in the first place, only with syncing a pre-existing file.

  7. Nicholas Basso


    Dropbox. Windows 7 x64. I downgraded keepass to 228 and somehow while it did not work before it did now so I'm not complaining. This plugin seems odd but oauth is on its own a difficult protocol.

  8. Ybother_the_1st

    I'm getting the same issue. It has nothing to do with the version of KeePass - I've had this in older versions as well. This is such an ongoing issue, that another version of this was created recently - see THIS TOPIC. If anyone cares to merge the tickets, we may have a bigger group making noise about this.

    It looks like there is nothing being done about this issue. In fact, it looks like Devin pretty much abandoned this entire project. None of the items reported has any responses from him, and there is no indication that this will change. Last changes to anything here were on 10/2/14...

  9. Log in to comment