Issues

Issue #161 resolved

/usr/bin/virtualenvwrapper.sh:461: parse error near `}'

Anonymous created an issue

Hey, when sourcing the "virtualenvwrapper_lazy.sh" I get this parse error over and over when issuing the first virtualenvwrapper related command.

(The error doesnt go well with Bitbuckets markup language, so http://pastebin.com/xhVqk86L)

Everything works fine, when I use the "non-lazy" version.

I'm using virtualenv 1.8, virtualenvwrapper 3.6, zsh 5.0.

Comments (5)

  1. senft

    This is how I source it:

    export WORKON_HOME=$HOME/.virtualenvs
    export PROJECT_HOME=$HOME/Code/Python
    export VIRTUALENVWRAPPER_SCRIPT=/usr/bin/virtualenvwrapper.sh
    source /usr/bin/virtualenvwrapper_lazy.sh
    
  2. Doug Hellmann repo owner

    I really only have access to zsh 4 for testing, so it's possible that something is different in the way that script is handled. It creates a bunch of functions corresponding to the commands normally loaded by virtualenvwrapper.sh which are replaced the first time one is run. That's a little tricky.

    Could you run these commands in a fresh shell window and provide the output:

    {{{ $ source /usr/bin/virtualenvwrapper_lazy.sh # don't do this again if your login script does it $ whence -f mkvirtualenv }}}

  3. senft

    With the lazy version sourced, I get this:

    [jln@das-eck:~] $ whence -f mkvirtualenv 
    mkvirtualenv () {
        virtualenvwrapper_load
        mkvirtualenv "$@"
    }
    
  4. senft

    Ok. This gets caused by this little alias:

    alias done="cd ~/Downloads/"
    

    It just came to me, that it might not be a good idea to override a keyword ;) So this is fixed then...

  5. Log in to comment