Issues

Issue #197 resolved

Installation with pip fails

Mike Fisher
created an issue

Hello,

I can't install 4.1.1 with pip:

~ $> pip install virtualenvwrapper
Downloading/unpacking virtualenvwrapper
  Downloading virtualenvwrapper-4.1.1.tar.gz (81kB): 81kB downloaded
  Running setup.py egg_info for package virtualenvwrapper
    warning: no previously-included files found matching '.gitignore'
    warning: no previously-included files found matching '.gitreview'
    warning: no previously-included files matching '*.pyc' found anywhere in distribution
    zip_safe flag not set; analyzing archive contents...
    pbr.d2to1.tests.__pycache__.__init__.cpython-33: module references __file__

    Installed /tmp/pip-build-mbfisher/virtualenvwrapper/pbr-0.5.19-py3.3.egg
    Searching for setuptools-git>=0.4
    Reading http://pypi.python.org/simple/setuptools_git/
    Best match: setuptools-git 1.0
    Downloading https://pypi.python.org/packages/source/s/setuptools-git/setuptools-git-1.0.tar.gz#md5=de63b541a10c2b83caa478c687458b16
    Processing setuptools-git-1.0.tar.gz
    Writing /tmp/easy_install-u5ecki/setuptools-git-1.0/setup.cfg
    Running setuptools-git-1.0/setup.py -q bdist_egg --dist-dir /tmp/easy_install-u5ecki/setuptools-git-1.0/egg-dist-tmp-asjjn4

    Installed /tmp/pip-build-mbfisher/virtualenvwrapper/setuptools_git-1.0-py3.3.egg
    Traceback (most recent call last):
      File "<string>", line 16, in <module>
      File "/tmp/pip-build-mbfisher/virtualenvwrapper/setup.py", line 7, in <module>
        pbr=True,
      File "/usr/lib/python3.3/distutils/core.py", line 109, in setup
        _setup_distribution = dist = klass(attrs)
      File "/usr/lib/python3.3/site-packages/setuptools/dist.py", line 225, in __init__
        _Distribution.__init__(self,attrs)
      File "/usr/lib/python3.3/distutils/dist.py", line 261, in __init__
        self.finalize_options()
      File "/usr/lib/python3.3/site-packages/setuptools/dist.py", line 258, in finalize_options
        ep.load()(self, ep.name, value)
      File "/tmp/pip-build-mbfisher/virtualenvwrapper/pbr-0.5.19-py3.3.egg/pbr/core.py", line 117, in pbr
        if isinstance(dist.metadata.version, integer_types + (float,)):
    TypeError: unsupported operand type(s) for +: 'type' and 'tuple'
    Complete output from command python setup.py egg_info:
    warning: no previously-included files found matching '.gitignore'

warning: no previously-included files found matching '.gitreview'

warning: no previously-included files matching '*.pyc' found anywhere in distribution

zip_safe flag not set; analyzing archive contents...

pbr.d2to1.tests.__pycache__.__init__.cpython-33: module references __file__



Installed /tmp/pip-build-mbfisher/virtualenvwrapper/pbr-0.5.19-py3.3.egg

Searching for setuptools-git>=0.4

Reading http://pypi.python.org/simple/setuptools_git/

Best match: setuptools-git 1.0

Downloading https://pypi.python.org/packages/source/s/setuptools-git/setuptools-git-1.0.tar.gz#md5=de63b541a10c2b83caa478c687458b16

Processing setuptools-git-1.0.tar.gz

Writing /tmp/easy_install-u5ecki/setuptools-git-1.0/setup.cfg

Running setuptools-git-1.0/setup.py -q bdist_egg --dist-dir /tmp/easy_install-u5ecki/setuptools-git-1.0/egg-dist-tmp-asjjn4



Installed /tmp/pip-build-mbfisher/virtualenvwrapper/setuptools_git-1.0-py3.3.egg

Traceback (most recent call last):

  File "<string>", line 16, in <module>

  File "/tmp/pip-build-mbfisher/virtualenvwrapper/setup.py", line 7, in <module>

    pbr=True,

  File "/usr/lib/python3.3/distutils/core.py", line 109, in setup

    _setup_distribution = dist = klass(attrs)

  File "/usr/lib/python3.3/site-packages/setuptools/dist.py", line 225, in __init__

    _Distribution.__init__(self,attrs)

  File "/usr/lib/python3.3/distutils/dist.py", line 261, in __init__

    self.finalize_options()

  File "/usr/lib/python3.3/site-packages/setuptools/dist.py", line 258, in finalize_options

    ep.load()(self, ep.name, value)

  File "/tmp/pip-build-mbfisher/virtualenvwrapper/pbr-0.5.19-py3.3.egg/pbr/core.py", line 117, in pbr

    if isinstance(dist.metadata.version, integer_types + (float,)):

TypeError: unsupported operand type(s) for +: 'type' and 'tuple'

----------------------------------------
Command python setup.py egg_info failed with error code 1 in /tmp/pip-build-mbfisher/virtualenvwrapper
Storing complete log in /home/mbfisher/.pip/pip.log

Looks to be something to do with pbr?

M

Comments (6)

  1. Log in to comment