Issues

Issue #226 wontfix

Cannot install with pip --user --egg

dwt
created an issue

I'm having the problem that installation of virtualenvwrapper fails when the --egg option is set to pip (which is something I have globally set, to ensure that namespace packages work after installation).

Now I really do not like namespace packages, but I do need them to work and without me having to think about them every time (i.e. debug for a while until I remember why they are broken).

So virtualenvwrapper should install cleanly with this flag set.

See debug output below

# slighly shortened    
    Installed /private/var/folders/qs/j5f7cnyj1cx36tg8j4vh5q0h0000gn/T/pip_build_dwt/virtualenvwrapper/pbr-0.6-py2.7.egg
    [pbr] Processing SOURCES.txt
    warning: LocalManifestMaker: standard file '-c' not found

    warning: no previously-included files found matching '.gitignore'
    warning: no previously-included files found matching '.gitreview'
    warning: no previously-included files matching '*.pyc' found anywhere in distribution
    warning: no files found matching '*.html' under directory 'docs'
    warning: no files found matching '*.css' under directory 'docs'
    warning: no files found matching '*.js' under directory 'docs'
    warning: no files found matching '*.png' under directory 'docs'
Requirement already satisfied (use --upgrade to upgrade): virtualenv in /Users/dwt/Library/Python/2.7/lib/python/site-packages (from virtualenvwrapper)
Requirement already satisfied (use --upgrade to upgrade): virtualenv-clone in ./virtualenv_clone-0.2.4-py2.7.egg (from virtualenvwrapper)
Requirement already satisfied (use --upgrade to upgrade): stevedore in /Users/dwt/Library/Python/2.7/lib/python/site-packages (from virtualenvwrapper)
Installing collected packages: virtualenvwrapper
  Running setup.py install for virtualenvwrapper
    Requirement already satisfied (use --upgrade to upgrade): virtualenv in /Users/dwt/Library/Python/2.7/lib/python/site-packages
    Requirement already satisfied (use --upgrade to upgrade): virtualenv-clone in /Users/dwt/Library/Python/2.7/lib/python/site-packages/virtualenv_clone-0.2.4-py2.7.egg
    Requirement already satisfied (use --upgrade to upgrade): stevedore in /Users/dwt/Library/Python/2.7/lib/python/site-packages
    Cleaning up...
    error: package directory 'virtualenvwrapper' does not exist
    Complete output from command /usr/bin/python -c "import setuptools, tokenize;__file__='/private/var/folders/qs/j5f7cnyj1cx36tg8j4vh5q0h0000gn/T/pip_build_dwt/virtualenvwrapper/setup.py';exec(compile(getattr(tokenize, 'open', open)(__file__).read().replace('\r\n', '\n'), __file__, 'exec'))" install --record /var/folders/qs/j5f7cnyj1cx36tg8j4vh5q0h0000gn/T/pip-L0s1Vi-record/install-record.txt --compile --user:
    running install

Requirement already satisfied (use --upgrade to upgrade): virtualenv in /Users/dwt/Library/Python/2.7/lib/python/site-packages

Requirement already satisfied (use --upgrade to upgrade): virtualenv-clone in /Users/dwt/Library/Python/2.7/lib/python/site-packages/virtualenv_clone-0.2.4-py2.7.egg

Requirement already satisfied (use --upgrade to upgrade): stevedore in /Users/dwt/Library/Python/2.7/lib/python/site-packages

Cleaning up...

running build

running build_py

error: package directory 'virtualenvwrapper' does not exist

----------------------------------------
Cleaning up...
Command /usr/bin/python -c "import setuptools, tokenize;__file__='/private/var/folders/qs/j5f7cnyj1cx36tg8j4vh5q0h0000gn/T/pip_build_dwt/virtualenvwrapper/setup.py';exec(compile(getattr(tokenize, 'open', open)(__file__).read().replace('\r\n', '\n'), __file__, 'exec'))" install --record /var/folders/qs/j5f7cnyj1cx36tg8j4vh5q0h0000gn/T/pip-L0s1Vi-record/install-record.txt --compile --user failed with error code 1 in /private/var/folders/qs/j5f7cnyj1cx36tg8j4vh5q0h0000gn/T/pip_build_dwt/virtualenvwrapper
Storing debug log for failure in /Users/dwt/Library/Logs/pip.log

Comments (1)

  1. Log in to comment