Issues

Issue #141 wontfix

Python 3 octal number breaks virtualenvwrapper 3.4 installation on Python 2.4

Anonymous created an issue

{{{ [vagrant@vagrant-centos-5-6 ~]$ sudo pip install virtualenv virtualenvwrapper Downloading/unpacking virtualenv Downloading virtualenv-1.7.1.2.tar.gz (2.1Mb): 2.1Mb downloaded Running setup.py egg_info for package virtualenv warning: no previously-included files matching '.' found under directory 'docs/_templates' Downloading/unpacking virtualenvwrapper Downloading virtualenvwrapper-3.4.tar.gz (795Kb): 795Kb downloaded Running setup.py egg_info for package virtualenvwrapper Downloading http://pypi.python.org/packages/source/d/distribute/distribute-0.6.10.tar.gz Extracting in /tmp/tmp07fgab Now working in /tmp/tmp07fgab/distribute-0.6.10 Building a Distribute egg in /home/vagrant/build/virtualenvwrapper /home/vagrant/build/virtualenvwrapper/distribute-0.6.10-py2.4.egg /usr/lib64/python2.4/distutils/dist.py:236: UserWarning: Unknown distribution option: 'provides' warnings.warn(msg) Installing collected packages: virtualenv, virtualenvwrapper Running setup.py install for virtualenv warning: no previously-included files matching '.' found under directory 'docs/_templates' Installing virtualenv script to /usr/bin Running setup.py install for virtualenvwrapper /usr/lib64/python2.4/distutils/dist.py:236: UserWarning: Unknown distribution option: 'provides' warnings.warn(msg) changing mode of build/scripts-2.4/virtualenvwrapper.sh from 644 to 755 changing mode of build/scripts-2.4/virtualenvwrapper_lazy.sh from 644 to 755 Skipping installation of /usr/lib/python2.4/site-packages/virtualenvwrapper/init.py (namespace package) File "/usr/lib/python2.4/site-packages/virtualenvwrapper/hook_loader.py", line 23 prevumask = os.umask(0o002) ^ SyntaxError: invalid syntax Installing /usr/lib/python2.4/site-packages/virtualenvwrapper-3.4-py2.4-nspkg.pth changing mode of /usr/bin/virtualenvwrapper_lazy.sh to 755 changing mode of /usr/bin/virtualenvwrapper.sh to 755 Successfully installed virtualenv virtualenvwrapper Cleaning up... [vagrant@vagrant-centos-5-6 ~]$ }}}

Comments (2)

  1. Anonymous

    I see that the release history says you dropped support for Python 2.4.

    The PyPI page still indicates that virtualenvwrapper is tested under Python 2.4 though:

    "Python Versions

    virtualenvwrapper is tested under Python 2.4 - 2.7."

  2. Log in to comment