Fresh install on postgres throws "No Shop matches the given query."

Issue #18 resolved
Simone Orsi
created an issue

Hi, following I created a fresh install of lfs running on a postgres db.

What's weird is that when you first try to access http://localhost:8000/manage you get a "No Shop matches the given query."... of course! I just created you! :)

I tested with sqlite and it works smoothly so I think there's something wrong w/ postgres startup sql.

Is there any workaround for this (aside fill in by hand some data table by table)? Any ready-to-use shop skeleton?

Cheers, SimO

Comments (10)

  1. Simone Orsi reporter

    Hi Kai, thanks for the answer.

    It seems I found another problem. A buildout-related problem: I do not have any "parts" called lfs! :) (A couple of day ago I tried the BO from "" which didn't work but it had a part called "lfs")

    That command did nothing BUT it should tell me "can't find this path" or whatever... instead of doing nothing at all. However I tried:

    $ bin/django loaddata eggs/django_lfs-0.2.3-py2.6.egg/lfs/core/fixtures/lfs_initial.xml

    and it worked with the following output:

    Installing xml fixture 'eggs/django_lfs-0.2.3-py2.6.egg/lfs/core/fixtures/lfs_initial' from absolute path. Installed 9 object(s) from 1 fixture(s)

    And know I can login! :)

    Attached you find my current BO (the only thing I changed is sqlite3/psycopg2 in eggs section)

    Should I file an issue for this BO?

  2. Simone Orsi reporter

    Sorry, I didn't explained myself clearly :)

    I wanted to say "1st I tried the code from google but it didn't work at all"

    Today I followed and I got the error I reported that fortunately was fixed with your hint ;)

    So, my answer is this:

    works smoothly BUT you have to launch:

    "bin/django loaddata path/to/your/eggs/django_lfs-xxx/lfs/core/fixtures/lfs_initial.xml"

    in order to syncdb.

    Thanks a lot for your help!

  3. Anonymous

    Hi, I did it. It's here I tried to make "pull request" but it bounces me outside and nothing seems to happen except that I have to login again :)

    I'm sorry I'm used to launchpad but I'm new to bitbucket and probably I'm doing something wrong :/ I promise I'll study deeeeply how it works :)

  4. Log in to comment