1. Kai Diefenbach
  2. django_workflows
  3. Issues
Issue #1 resolved

Circle imports at models/utils modules

Łukasz Balcerzak
created an issue

It seems there are circle imports within models.py/utils.py modules..

{{{ /Users/user/.virtualenvs/d12/lib/python2.6/site-packages/workflows/models.py in <module>() 11 12 # workflows imports

---> 13 import workflows.utils 14 15 class WorkflowBase(object):

/Users/user/.virtualenvs/d12/lib/python2.6/site-packages/workflows/utils.py in <module>() 4 5 # workflows imports

----> 6 from workflows.models import StateInheritanceBlock 7 from workflows.models import StateObjectRelation 8 from workflows.models import StatePermissionRelation

ImportError: cannot import name StateInheritanceBlock }}}

Am using django-workflows-1.0a2, pulled from pypi.

Comments (5)

  1. Anonymous

    not sure if this is related, but am having difficulties myself. tried installing 1.0a2 instead of a3, but same problem:

    from workflows.models import Workflow

    Traceback (most recent call last): File "<console>", line 1, in <module> File "/usr/local/lib/python2.6/dist-packages/django_workflows-1.0a2-py2.6.egg/workflows/models.py", line 13, in <module> import workflows.utils File "/usr/local/lib/python2.6/dist-packages/django_workflows-1.0a2-py2.6.egg/workflows/utils.py", line 6, in <module> from workflows.models import StateInheritanceBlock ImportError: cannot import name StateInheritanceBlock

  2. phoebebright

    Not sure if this helps, but am having difficulties with 1.0a3. Won't sync at all - no error messages, just no tables created. If I run tests it's not looking for the workflows tests either. Deleted all other versions of workflows on my disk and put workflows in the same folder as my other apps. Just won't sync. Put 1.0a1 back and that syncs fine.

  3. Log in to comment