1. dirkbaechle
  2. SCons_Qt4
  3. Issues
Issue #8 new

building av Qrc4 file destroys sconsign.dblite file

Ivan Nedrehagen
created an issue

After adding a Qrc4 build into our somewhat complex build the whole sconsign.dblite is destroyed. So whenever we build, we get complete rebuilds, and explanation is that no previous build information is found.

After some experimenting I managed to get rid of this problem. What I needed to do was puzzling enough to comment out the prefix=... part of the __qrc_builder, after this fix and a rebuild the builds behave again.

If this is an issue with SCons itself or the Qt4 tools I don't know. But hopefully it is worth to take a look at.

Comments (1)

  1. dirkbaechle repo owner

    Hi Ivan,

    and thanks for your error report. I find it hard to believe that a simple prefix/suffix corrupts the signature database of SCons. But this is what you see, so let's find out what goes wrong:

    - Which version of SCons are you using? - Under which OS? - Is the signature database file sconsign.dblite removed completely, or does it seem to hold corrupt data such that SCons claims that it can't find any useful info inside? - Have you tried running the build process on another OS/machine? With the same results? - Have you tried running a simple Qrc4 example, something along the lines of "qrc/basic/SConscript" in the Qt4 Tool's "test" directory? - Would it be possible for you to send me one of the allegedly corrupted sconsign.dblite files for deeper analysis? Or can you come up with a simple example, demonstrating the issue?

    Best regards,


  2. Log in to comment