Error opening Individual and Template files

Issue #413 resolved
Susan Spencer created an issue

On Ubuntu 14.04, 64bit latest test build from Launchpad:

In Tape, Create/Edit: Can't open individual and template files. This error message appears: 'This file already opened in another window'

Tried creating new .vit file, no errors, works fine. But can't open it, or any other measurement file. Always get 'opened in another window' error message.

Comments (44)

  1. Susan Spencer reporter

    If I open Valentina, create a new pattern with a 1st patternpiece (with 1st pattern point A) and before saving to a pattern file (*.val) then I can Load a measurement file.

    Also after saving to a pattern file (.val), I can load a measurement file. So it's independent of a saved .val. It needs to have something in Draw mode, perhaps?

    Can't open a measurement file if no pattern is loaded.

  2. Roman Telezhynskyi repo owner

    You can't open the same file twice. But you can avoid this. Just delete .lock file. The file in the same folder. On Ubuntu enable showing hiden files.

  3. Susan Spencer reporter

    'show hidden files' was enabled. Tried this again. Closed Valentina. Checked directories for *.lock files, checking for 'show hidden files' - no .lock files Opened Valentina Measurements, Create/Edit <Load options are grey/disabled> File/Open template/t_interactivos_template.vit !Error message! Quit Tape

    Measurements,Create/Edit <Load options are grey/disabled> Open Invidual/marie_new.vit !Error message! Quit Tape

    File/New patternpiece1 Measurements,Create/Edit <Load options are enabled> File/Open Template t_interactivos_template.vit !error message! Quit Tape

    Measurements, Load Individual t_interactivos_template <did not get message>

    Maybe it is Create/Edit? Load Individual is enabled after creating a pattern piece Load Individual works fine

  4. Roman Telezhynskyi repo owner

    When Valentina loads measurements It doesn't check .lock file. No, it is something different. I have found bug in code. But it is not what we are looking.

  5. Roman Telezhynskyi repo owner

    Seek old .lock file in the same folder where your template file and vit file.

  6. Susan Spencer reporter

    Did that, tried to video the process but the file gets to big. Nothing in the new folder except one individual file - marie_new.vit

  7. Susan Spencer reporter

    No, it did not help. Creating a new folder and copying one file to it did not change anything.

  8. Roman Telezhynskyi repo owner

    Not now, only after you will pull my last changes. And what should i do? It is 02.46 am here.

  9. Susan Spencer reporter

    I just pulled your latest changes. Sorry, but if this isn't fixed I can't give the training today!!!!! Its a 3 hour training session that they advertised.

  10. Susan Spencer reporter

    If you can stay up with me for a bit, I'd really appreciate it. I know it's frustrating. I've been dealing with political issues and didn't test ahead of time.

  11. Susan Spencer reporter

    Ah, I copied it to a new folder.

    Opened file in gedit to look at read-only. Read-only is 'false' I changed gender from 'unknown' to female. changed birthday from '1800-01-01' to '1900-01-01' and saved.

    opened Valentina created new pattern piece updated Preferences to new folder 'm2' opened Measurements, Create/Edit, then Open Individual, marie_new.vit Did not click Show, went right to creating A1 with Point from Distance and Angle Entered 'formula', and selected radiobutton for 'Measurements' The measurements are listed. Saved pattern Clicked 'Show' in Tape The measurements are listed.

  12. Roman Telezhynskyi repo owner

    Maybe some tape zombie process block all. Check your system or rebut if don't know how to check.

  13. Susan Spencer reporter

    It seems fine now. I can open, add, create new, create from existing, etc. Thanks for staying up with me on this.

  14. Log in to comment