Commits

Anonymous committed 3192756

older Module::Build versions don't do test_requires

Comments (0)

Files changed (1)

         'Try::Tiny'                => 0,
     },
 
-    test_requires => {
+    (
+        Module::Build->VERSION < 4.004
+        ? 'build_requires'
+        : 'test_requires'
+      ) => {
         'Getopt::Long'    => 0,
         'IO::Handle'      => 0,
         'IO::Pipe'        => 0,
         'Sub::Quote'      => 0,
         'Test::Exception' => 0,
         'Test::More'      => 0,
-    },
+      },
 
     meta_merge => {
         resources => {