NetworkError: undefined after successful connection test

Issue #88 resolved
Alex Finch created an issue

I can successfully test the connection to my GitLab group but when I click OK to create the configuration, it returns a NetworkError: undefined. Because of this, I am unable to make any connections with Jigit. See below

Comments (8)

  1. Dmitrii Apanasevich repo owner

    Hi Alex,

    Any information from JIRA log and browser console (on Windows F12 -> console) would be helpful.

  2. Alex Finch reporter

    Hi Dimitri,

    I opened the browser console and this is what I see in the log when I click ‘OK’ and get the error. Having difficulty getting the Jira logs at the moment (replaced the url with ***):

    SEC7111: [Mixed-Content] The origin '***.us' was loaded in a secure context but tried to load an insecure resource at '***.us/rest/jigit/1.0/repo/add'.

  3. Dmitrii Apanasevich repo owner

    That’s enough. The problem is clear, i’ll provide the fixed version ASAP.

  4. Dmitrii Apanasevich repo owner

    Hi Alex,

    Apparently, the issue is caused by misconfiguration of your Jira instance. I’ve asked a question and got an extremely detailed answer here

    Please, try to check Base Url property in Jira configuration, Connectors element in server.xml and let me know whether the issue solved.

  5. Dmitrii Apanasevich repo owner

    Have you managed to configure Jira setting to get rid of the error? Is the issue still actual?

  6. Alex Finch reporter

    HI Dimitri, Thanks for your response, I am looking at your solution now. I will let you know my results.

  7. Alex Finch reporter

    Dmitrii, I think I see our problem, the routing terminates the TLS then passes traffic through HTTP. I am going to take a look to see if I can terminate after routing traffic.

  8. Log in to comment