Issue #2 resolved

linker flag for boost 1.5's libboost_system with cmake 2.8.4+

Anonymous created an issue

For boost 1.5+ libbost_system.so needs to be linked explicitely or you'll get the error.

/usr/bin/ld: CMakeFiles/ibex.dir/ibex.cpp.o: undefined reference to symbol '_ZN5boost6system15system_categoryEv'
/usr/bin/ld: note: '_ZN5boost6system15system_categoryEv' is defined in DSO /usr/lib/libboost_system.so.1.52.0 so try adding it to the linker command line
/usr/lib/libboost_system.so.1.52.0: could not read symbols: Invalid operation

Allegedly it is as easy as adding "system" to set(OGRE_BOOST_COMPONENTS ...) but it didn't work for me and I don't know enough about cmake to know why.

Comments (3)

  1. Hesham Wahba repo owner

    Thanks for the tip Christoph. I'll add that when I next update the Linux branch. Most of the work has been focused on the Windows and Mac ones recently as those should have SDK support quickest :)

  2. Hesham Wahba repo owner

    Latest version should work now. Please check the README.md for details on updated packages needed. Ubuntu 13.04 is what I'm using, also you should have the OculusSDK extracted in the Downloads folder or a level above the ibex folder.

  3. Log in to comment