1. Augie Fackler
  2. hg-git
Issue #38 wontfix

tags

Ulrich Van Den Hekke
created an issue

Hi,

I clone git repository on my server and that work.

Now i want to clone this mercurial (hg-git) repository in my compyter to develop.

The problem is the tags are removed on the local computer (file .hg/git-tags is not copied when clone). How can i conserve tag on my new repository ?

Comments (3)

  1. Jason R. Coombs

    Ulrich: I suspect the reason this was closed as wontfix is because it's a difficult if not impossible problem to solve without modifying Mercurial itself.

    Mercurial expects tags to be stored in the .hgtags file in the repository, but when cloning a git repo, those tags are stored outside of the repo... so a clone of a Mercurial checkout of a git repo won't have the Mercurial constructs to represent the tags, so without Mercurial being aware of tags stored outside of the commit history, it simply doesn't see the git tags.

  2. Log in to comment