A network intensive clone

Create issue
Issue #182 resolved
NicolasL created an issue

In my svn repo, the project I tried to clone is in a subfolder: https://svn.myhost/repos/product/ui/admin-ui

There are a lot of stuff in https://svn.myhost/repos/product

And in the history there is a move from https://svn.myhost/repos/project to https://svn.myhost/repos/product

So when I clone I got this: {{{ $ hg clone svn+https://svn.myhost/repos/product/ui/admin-ui destination directory: admin-ui [r15828] nlalevee: move abort: ("REPORT of 'https://svn.myhost/repos/product/ui/admin-ui': Could not read chunk size: Secure connection truncated (https://svn.myhost)", 175002) }}}

Actually this commands runs a bit, there is a lot of stuff downloaded as my network monitor shows me. The revision 15828 is the big move. {{{ $ svn log https://svn.myhost/repos/product/ui/admin-ui -v -r15828


r15828 | nlalevee | 2009-10-14 14:13:11 +0200 (Wed, 14 Oct 2009) | 2 lines Changed paths: A /product (from /project:15827) D /project

move


}}}

I don't know who is really responsible for the closed connection, maybe the httpd serving the subversion repository. But maybe hgsubversion could try to skip that revision ? as it is quite irrelevant for the history of admin-ui.

Comments (6)

  1. hennejg

    Same problem here. I tried falling back to svn+http from svn+https but the same error comes up except for it saying "Could not read chunk size: Connection truncated".

  2. hennejg

    Bump! Ok, maybe something a bit more polite, like Bump? :-) It would be awfully nice, if hg were an alternative for me, but this issue is a showstopper.

  3. Former user Account Deleted

    I get this too. I'd love to be able to use hg as a client for our corporate svn repo, but am unable to check out big trees because of this.

  4. Dan Villiom Podlaski Christiansen

    That's good to hear! As a result, I'm closing this issue. (I wonder what fixed it, though; was it an update to hgsubversion, Subversion or Python?)

  5. Log in to comment